Bug 1258015 - [RFE] Rebase GNOME to version 3.18 (or latest)
[RFE] Rebase GNOME to version 3.18 (or latest)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gtk3 (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Benjamin Otte
Desktop QE
: FutureFeature, Rebase
Depends On:
Blocks: 1250859 1317649 1439702
  Show dependency treegraph
 
Reported: 2015-08-28 12:20 EDT by Tony James
Modified: 2017-09-12 14:48 EDT (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
: 1317649 (view as bug list)
Environment:
Last Closed: 2017-09-12 14:48:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony James 2015-08-28 12:20:13 EDT
We should strive to keep GNOME as up-to-date as possible while RHEL is in the Production 1 phase of it's lifecycle.  GNOME 3.18 (when released) will bring a number of user facing improvements including Wayland support [1] [2]. GNOME 3.18 should be released early enough to be considered for RHEL 7.3.  In order to increase usage of RHEL for desktops and workstations it is important for users to have access to the latest graphical tools.

[1] https://wiki.gnome.org/ReleasePlanning/FeaturePlans
[2] https://wiki.gnome.org/Initiatives/Wayland
Comment 3 Robin R. Price II 2015-11-12 10:13:14 EST
Gnome 3.18 Released:

https://www.gnome.org/news/2015/09/gnome-3-18-released-brings-big-improvements/

Major new features in GNOME 3.18 include:

* Google Drive integration in Files
* Firmware updates through Software
* Automatic screen brightness
* Touchpad gestures
* Several new applications: Calendar and Characters
* Significant improvements to Files, Boxes and Polari

Gnome 3.16 Released:

https://help.gnome.org/misc/release-notes/3.16/index.html.en
https://help.gnome.org/misc/release-notes/3.16/more.html.en

Major new features in GNOME 3.16 include:

* Notifications Reimagined
* Files Improvements
* Updated Visuals
* New-Look Scrollbars
* Updated Image Viewer
* New Preview Applications
* Better Boxes
* Improved Maps
Comment 5 Tomas Pelka 2016-02-10 13:11:11 EST
As discussed with Matthias, requesting move to 7.5 instead of 7.4.

Reason:
Every even release is reserved already for Xorg rebase. I would like to avoid this concurrence if possible.

-Tom
Comment 6 Matthias Clasen 2016-02-10 13:23:05 EST
(In reply to Tomas Pelka from comment #5)
> As discussed with Matthias, requesting move to 7.5 instead of 7.4.
> 
> Reason:
> Every even release is reserved already for Xorg rebase. I would like to
> avoid this concurrence if possible.
> 

When I brought this up with Christian, he said that he expects every release to have an Xorg rebase, going forward. So this idea might need some more discussion.
Comment 7 Marc-Andre Lureau 2016-03-14 13:57:50 EDT
Hi, spice-gtk would like to depend on gtk+ 3.16 for gl support on wayland. Is this the proper bug to track for such a rfe? thanks
Comment 8 Tomas Pelka 2016-03-14 14:12:04 EDT
(In reply to Marc-Andre Lureau from comment #7)
> Hi, spice-gtk would like to depend on gtk+ 3.16 for gl support on wayland.
> Is this the proper bug to track for such a rfe? thanks

Marc-Andre I would rather create a new RFE and make it blocking this bz.

Make sense?

-Tom
Comment 9 David 2016-06-26 09:14:00 EDT
I just wanted to add another vote to include this sooner. I built 3.20 in Copr for el7, and it was not very hard. No code changes were done, sources taken from Fedora 24. Only SPEC files modified to remove wayland dependencies (wayland builds fine, but it requires a rebase of mesa in the end to work), and to remove their checks against python3 for rhel. I used python 3.3 as the base, though 3.4 should also work just fine. Feel free to steal my spec files if it helps to push this sooner. Just another vote for a 7.3 rebase.
https://copr.fedorainfracloud.org/coprs/duh/GNOME_3.20_for_RHEL_and_CentOS_7.x/
Comment 10 Robin R. Price II 2016-06-26 11:02:58 EDT
Thanks David!

I will make another case.  This is a personal inside Red Hat use case.

I help support over ~20 inside sales account managers.  The teams use e-mail and instant messaging heavily.  The notification system HAS been causing delays.  A GNOME rebase to 3.20+ would help this issue we are facing.

Work around for now:

Install a GNOME extension to change the notification system.
Does not completely work as well as the newer GNOME 3.20 notification system.

Please consider a more aggressive rebase inclusion.  


~rp
Comment 11 Neal Gompa 2016-06-26 11:12:18 EDT
I'd like to add my support for a GNOME rebase to 3.20 for 7.3 as well.

Among other things, I'm looking forward to the improved desktop virtualization stuff. I hope that updated qemu-kvm and libvirt would ship with the rebase, so that we can use all the cool new stuff, like UEFI booting VMs, virtio-gpu GL through SPICE, etc.

In my particular use-case, I'd like to be able to use hardware accelerated graphics wherever possible, as a lot of the Linux distributions these days ship with desktop environments that require it to be reasonably performant.

I'd also like to be able to boot virtual machines that use UEFI, especially for development and P2V scenarios.
Comment 12 David 2016-10-14 15:34:59 EDT
A followup after the release of GNOME 3.22. Due to the need of more packages (especially Evolution) needing the latest WebKitGTK4, GNOME 3.20 is likely the last that can be "fully" built for RHEL. I have successfully built 3.22 for EL7 in Copr, and its fully usable, however evolution needed to stay behind at 3.20, and Epiphany is not included (though firefox is the EL7 default browser). So it could be updated in EL7 if evolution is skipped, otherwise it would have to wait for RHEL 8.

(Side note, I tried too hard to get the latest WebKitGTK4 built on gcc 4.8, but found it impossible. I could build gcc 6.2 on el7 and then compile webkitgtk4 on that, but that defeats the purpose and needs way too many rebuilds throughout the OS).
Comment 13 Neal Gompa 2016-10-15 12:52:47 EDT
@David:

I suspect that the usage of the Devtoolset-4 SCL might enable you to build the latest webkitgtk4 for EL7. It provides GCC 5.2.x, which should be recent enough to make things work. Alternatively, Devtoolset-6 is supposed to arrive pretty soon, bringing with it GCC 6 for EL7 users.
Comment 14 Neal Gompa 2017-04-14 11:20:04 EDT
GNOME 3.24 released:

https://help.gnome.org/misc/release-notes/3.24/

Interesting highlights:

* Night mode which makes the screen color warmer in the evening. It can help to prevent sleeplessness and eye strain.

* Revamped Settings with more coherent layout and intuitive manipulation of settings.

* GNOME Recipes for storing your favorite food recipes. :)

* GNOME Games improvements. :)

* Improvements to notifications and GNOME Web (epiphany)

* Polari now lets you click on usernames to get a popover menu to select actions

* Support for multiple graphics cards

* Flatpak support in GNOME Software

Can we have GNOME 3.24 for EL 7.4?
Comment 15 Tomas Pelka 2017-04-14 13:51:52 EDT
(In reply to Neal Gompa from comment #14)
> GNOME 3.24 released:
> 
> https://help.gnome.org/misc/release-notes/3.24/
> 
> Interesting highlights:
> 
> * Night mode which makes the screen color warmer in the evening. It can help
> to prevent sleeplessness and eye strain.
> 
> * Revamped Settings with more coherent layout and intuitive manipulation of
> settings.
> 
> * GNOME Recipes for storing your favorite food recipes. :)

This app won't be most likely not supported anyway, for example we are not shipping gnome-music, gnome-maps etc. When new gnome app appear it does not necessary mean if will be automatically shipped in RHEL. Simply Recipes is not enterprise enough :)

> 
> * GNOME Games improvements. :)

Same as above

> 
> * Improvements to notifications and GNOME Web (epiphany)

Epiphany is not shipped ans supported within RHEL.

> 
> * Polari now lets you click on usernames to get a popover menu to select
> actions

No support for Polari too.

> 
> * Support for multiple graphics cards
> 
> * Flatpak support in GNOME Software

As far as I know flatpack support is sufficient in 3.22.

> 
> Can we have GNOME 3.24 for EL 7.4?

No, this is not the plan. Simply because release cycle of gnome is not in sync with RHEL cycle. But don't worry we will deliver something.
Comment 16 Pat Riehecky 2017-09-12 12:08:05 EDT
I believe this is fixed in RHEL 7.4

Note You need to log in before you can comment on or make changes to this bug.