Bug 1258084 - plasmashell still feezes when notifications arrive while locked
plasmashell still feezes when notifications arrive while locked
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libxcb (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 19:07 EDT by Jonathan Wakely
Modified: 2015-10-08 11:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 09:07:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pull in candidate fix (2.02 KB, patch)
2015-09-16 14:17 EDT, Rex Dieter
no flags Details | Diff

  None (edit)
Description Jonathan Wakely 2015-08-28 19:07:28 EDT
as per https://bugzilla.redhat.com/show_bug.cgi?id=1193742

(gdb) bt 
#0  0x0000003959af72fd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x000000395e20a182 in _xcb_conn_wait () at /lib64/libxcb.so.1
#2  0x000000395e20ba17 in wait_for_reply () at /lib64/libxcb.so.1
#3  0x000000395e20bb21 in xcb_wait_for_reply () at /lib64/libxcb.so.1
#4  0x000000395da431f7 in _XReply () at /lib64/libX11.so.6
#5  0x0000003a5b2442fa in DRI2GetBuffersWithFormat () at /lib64/libGL.so.1
#6  0x0000003a5b244637 in dri2GetBuffersWithFormat () at /lib64/libGL.so.1
#7  0x00007f63a280c67b in intel_update_renderbuffers () at /usr/lib64/dri/i965_dri.so
#8  0x00007f63a280cb91 in intel_prepare_render () at /usr/lib64/dri/i965_dri.so
#9  0x00007f63a2800870 in brw_clear () at /usr/lib64/dri/i965_dri.so
#10 0x0000003d157263fa in QSGBatchRenderer::Renderer::renderBatches() () at /lib64/libQt5Quick.so.5
#11 0x0000003d1572bde2 in QSGBatchRenderer::Renderer::render() () at /lib64/libQt5Quick.so.5
#12 0x0000003d15737adf in QSGRenderer::renderScene(QSGBindable const&) () at /lib64/libQt5Quick.so.5
#13 0x0000003d1573832b in QSGRenderer::renderScene(unsigned int) () at /lib64/libQt5Quick.so.5
#14 0x0000003d1574871e in QSGRenderContext::renderNextFrame(QSGRenderer*, unsigned int) () at /lib64/libQt5Quick.so.5
#15 0x0000003d1579265b in QQuickWindowPrivate::renderSceneGraph(QSize const&) () at /lib64/libQt5Quick.so.5
#16 0x0000003d1576301b in QSGGuiThreadRenderLoop::renderWindow(QQuickWindow*) () at /lib64/libQt5Quick.so.5
#17 0x0000003d15764121 in QSGGuiThreadRenderLoop::event(QEvent*) () at /lib64/libQt5Quick.so.5
#18 0x0000003d09b544ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#19 0x0000003d09b59976 in QApplication::notify(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#20 0x0000003d0808361b in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#21 0x0000003d080d8bad in QTimerInfoList::activateTimers() () at /lib64/libQt5Core.so.5
#22 0x0000003d080d90b1 in timerSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQt5Core.so.5
#23 0x000000395be49a8a in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#24 0x000000395be49e20 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#25 0x000000395be49ecc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#26 0x0000003d080d9d8f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#27 0x0000003d08080daa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#28 0x0000003d08088e6c in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#29 0x000000000042ef16 in main ()
Comment 1 Rex Dieter 2015-09-16 12:12:34 EDT
Trying xserver fix,
http://lists.x.org/archives/xorg-devel/2015-September/047304.html
Comment 2 Rex Dieter 2015-09-16 13:16:52 EDT
OK, have a patched xorg-x11-server available in copr:
https://copr.fedoraproject.org/coprs/rdieter/libxcb/

Please test.
Comment 3 Rex Dieter 2015-09-16 14:15:54 EDT
I've pulled it into f22 branch now for some test builds.


airlied, I see you're currently rebasing things on f23+, would you mind pulling in this patch there?  (I'll attach, if that helps).

Or I can apply it to f23/master branches myself too, with your blessing.
Comment 4 Rex Dieter 2015-09-16 14:17:10 EDT
Created attachment 1074158 [details]
pull in candidate fix

Candidate for clients getting stuck waiting indefinitely for an idle event when a CRTC is turned off (#1256082,#1258084)
Comment 5 Fedora Update System 2015-09-24 08:18:48 EDT
xorg-x11-server-1.17.2-2.fc22.2 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16590
Comment 6 Fedora Update System 2015-09-24 08:57:31 EDT
xorg-x11-server-1.18.0-0.4.20150907.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16600
Comment 7 Fedora Update System 2015-09-25 12:33:14 EDT
xorg-x11-server-1.18.0-0.4.20150907.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xorg-x11-server'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16600
Comment 8 Fedora Update System 2015-09-26 20:38:59 EDT
xorg-x11-server-1.17.2-2.fc22.2 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xorg-x11-server'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16590
Comment 9 Fedora Update System 2015-10-03 13:45:49 EDT
xorg-x11-server-1.18.0-0.4.20150907.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2015-10-03 17:14:00 EDT
xorg-x11-server-1.17.2-2.fc22.2 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fredy Neeser 2015-10-08 08:32:15 EDT
Hi, thanks for the xorg-x11-server* update on Fedora 22!!!  I already had the impression that xorg updates in Fedora 22 are lagging somewhat behind upstream developments, so it's good to be able to do some incremental testing.

With Fedora 22 KDE and intel + nouveau drivers  (I'm on a Lenovo W530 laptop with LVDS driven by intel + ext. monitor driven by nouveau), I'm already having lots of issues to get/keep the external monitor (driven by nouveau) working, so I pay close attention also to xorg updates :-)

On this system, I had noted before that turning off the external monitor (or turning it back on after resuming from suspend) regularly caused my KDE session to crash.

In my testing, the update to xorg-x11-server* 1.17.2-2.fc22.2, specifically
  xorg-x11-server-Xorg.x86_64 1.17.2-2.fc22.2
  xorg-x11-server-Xwayland.x86_64 1.17.2-2.fc22.2
  xorg-x11-server-common.x86_64 1.17.2-2.fc22.2
  xorg-x11-drv-libinput.x86_64 0.14.0-1.fc22

causes two *new* problems:

1.  KDE now often comes up (after boot / first login) without any widgets on the external monitor (=primary display), just showing the KDE menu, and with the LVDS having a black background but otherwise working.
I found that a logout/login cycle often fixes this problem.
However, plasmashell then crashed at kde login, as I just reported here:
  https://bugs.kde.org/show_bug.cgi?id=353681

2.  Also, KDE with the new xorg has more difficulty to decide where the primary display is located -- during KDE startup (first startup after reboot), the primary display (KDE panel etc.) is being visibly moved from LVDS to the external monitor.

These problems did not exist with the previous xorg-x11 version:
  xorg-x11-server-Xorg.x86_64 1.17.1-11.fc22
  xorg-x11-server-Xwayland.x86_64 1.17.1-11.fc22
  xorg-x11-server-common.x86_64 1.17.1-11.fc22
  xorg-x11-drv-libinput.x86_64 0.9.0-1.fc22

so I wanted to document the new problems here, as well as the fact that plasmashell crashes at kde login, even after also applying today's update to
kde-runtime* (incl. kde-runtime-drkonqi) 15.08.1-2.fc22.

However, since my problems with the new xorg-x11-server don't exactly match the present bug description, should I open a new bug?

Please let me know if I can do something to help debug the 2 new issues further.


Perhaps the behavior of KDE with the new xorg-x11-server-1.17.2-2.fc22.2 sheds some light:

- Boot into kernel 4.1.3-201.fc22.x86_64 (with newer fedora kernels
  from 4.1.4 ... 4.1.6, the external monitor does not work at all)

- Login to KDE takes a long time:
  - First, dolphin windows appear CENTERED on the composite
    (LVDS + ext. monitor) display (NEW BEHAVIOR)
  - KDE desktop is briefly shown on wrong screen (LVDS)
  - Shortly thereafter, KDE desktop (incl. background and widgets)
    reappears briefly on the external monitor
  - Shortly thereafter - final view of KDE desktop (broken):
    - External monitor:
      - Desktop background and widgets have disappeared
      - KDE panel and menu appear and are working
    - LVDS:
      - Black background, but windows moved to it are displayed

- Switching to VT and back (on LVDS) works fine

- Logout/login again
  - The KDE desktop appears correctly
    - External monitor shows background (wallpaper) and widgets
    - LVDS shows background (blue graphical pattern)
  - KDE menu does NOT work (does not open when I click on it)
  - No Logout/Restart/Shutdown buttons
  - But after a couple of minutes ...
  - KDE menu suddenly DOES work

- Logout/login again
  - The KDE desktop appears correctly
    - External monitor shows background (wallpaper) and widgets
    - LVDS shows background (blue graphical pattern)
  - KDE menu DOES work immediately

- Another reboot into kernel 4.1.3-201.fc22.x86_64
- Login to KDE, KDE desktop broken (no widgets on primary display)
- Logout/login: Still same problem
- Logout/login again
  - The KDE desktop appears correctly
Comment 12 Rex Dieter 2015-10-08 09:07:54 EDT
the issues you report very unlikely has anything to do with this bug, yes, start a new one please, thanks.
Comment 13 Fredy Neeser 2015-10-08 11:32:32 EDT
(In reply to Rex Dieter from comment #12)
> the issues you report very unlikely has anything to do with this bug, yes,
> start a new one please, thanks.

OK, sure, I started a new bug

  https://bugzilla.redhat.com/show_bug.cgi?id=1269958
  xorg-x11-server update breaks KDE dual-monitor setup with intel/nouveau

for the new issues from comment #11.

Note You need to log in before you can comment on or make changes to this bug.