Bug 1258086 - Latest version does not write any logs
Latest version does not write any logs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 19:18 EDT by Patrick Uiterwijk
Modified: 2015-11-03 04:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 04:12:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Uiterwijk 2015-08-28 19:18:34 EDT
Description of problem:
After upgrading my wpa_supplicant on 2015-08-24 from 1:2.4-4.fc22.x86_64 to 1:2.4-3.fc22.x86_64, the log file has been empty.
[root@bofh log]# tail wpa_supplicant.log-20150825 
...
EAP-MSCHAPV2: Authentication succeeded
EAP-TLV: TLV Result - Success - EAP-TLV/Phase2 Completed
enp0s25: CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully

[root@bofh log]# tail wpa_supplicant.log
[root@bofh log]# 


Version-Release number of selected component (if applicable):
wpa_supplicant-1:2.4-3.fc22.x86_64

How reproducible:
Unknown

Steps to Reproduce:
1. Upgrade to the latest wpa_supplicant
2. Tail /var/log/wpa_supplicant.log

Actual results:
Empty file.

Expected results:
Standard wpa supplicant logs, as has been the case before.

Additional info:
Also the logs it reports to journald are empty:
[root@bofh log]# systemctl status wpa_supplicant.service 
● wpa_supplicant.service - WPA Supplicant daemon
   Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; disabled; vendor preset: disabled)
   Active: active (running) since 火 2015-08-25 01:05:57 CEST; 4 days ago
 Main PID: 2179 (wpa_supplicant)
   CGroup: /system.slice/wpa_supplicant.service
           └─2179 /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log -P /var/run/wpa_supplicant.pid

 8月 25 01:05:57 bofh.thuis.puiterwijk.org systemd[1]: Starting WPA Supplicant daemon...
 8月 25 01:05:57 bofh.thuis.puiterwijk.org systemd[1]: Started WPA Supplicant daemon.
[root@bofh log]# 


I am thinking wpa_supplicant may be the cause of networking issues on my wired connection (where I use 802.1X), but since there are no logs written I cannot verify this.
Comment 1 Patrick Uiterwijk 2015-08-28 20:10:36 EDT
So, it turns out that just the default verbosity has changed, as after creating a /etc/systemd/system/wpa_supplicant.service with -dd argument, I get logging again.

Perhaps it would be an idea to set it to -d in the packages unit file, so that at least the old amount of logs are still retained?
Comment 2 Fedora Admin XMLRPC Client 2015-10-14 10:50:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Lubomir Rintel 2015-11-03 04:12:27 EST
wpa_supplicant now (that is Rawhide, Fedora 24) uses syslog protocol for logging so the relevant logs should now land in journal.

Note You need to log in before you can comment on or make changes to this bug.