Bug 1258087 - RHOS provider refresh fails with " Multiple regions available choose one of these 'RegionOne,regionOne' "
RHOS provider refresh fails with " Multiple regions available choose one of t...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 19:23 EDT by Nandini Chandra
Modified: 2015-11-11 15:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 10:15:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2015-08-28 19:23:12 EDT
Description of problem:
----------------------
RHOS provider refresh fails with this error message:

Multiple regions available choose one of these 'RegionOne,regionOne' 

Snippet from evm.log

[----] E, [2015-08-28T04:35:54.871467 #23510:f31eac] ERROR -- : MIQ(EmsRefresh::Refreshers::OpenstackRefresher.refresh) EMS: [rhos6], id: [6] Refresh failed
[----] E, [2015-08-28T04:35:54.871637 #23510:f31eac] ERROR -- : [Fog::Errors::NotFound]: Multiple regions available choose one of these 'RegionOne,regionOne'  Method:[rescue in block in refresh]
[----] E, [2015-08-28T04:35:54.871710 #23510:f31eac] ERROR -- : /opt/rh/cfme-gemset/gems/fog-1.29.0/lib/fog/openstack/core.rb:154:in `authenticate_v2'
/opt/rh/cfme-gemset/gems/fog-1.29.0/lib/fog/openstack/orchestration.rb:237:in `authenticate'
/opt/rh/cfme-gemset/gems/fog-1.29.0/lib/fog/openstack/orchestration.rb:160:in `initialize'
/opt/rh/cfme-gemset/gems/fog-core-1.32.1/lib/fog/core/service.rb:115:in `new'
/opt/rh/cfme-gemset/gems/fog-core-1.32.1/lib/fog/core/service.rb:115:in `new'
/opt/rh/cfme-gemset/gems/fog-core-1.32.1/lib/fog/core/services_mixin.rb:16:in `new'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:71:in `raw_connect'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:47:in `block in raw_connect_try_ssl'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:40:in `rescue in try_connection'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:32:in `try_connection'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:44:in `raw_connect_try_ssl'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:126:in `connect'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:237:in `detect_service'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:155:in `detect_orchestration_service'
/var/www/miq/vmdb/app/models/ems_refresh/parsers/openstack.rb:32:in `initialize'
/var/www/miq/vmdb/app/models/ems_refresh/parsers/openstack.rb:9:in `new'
/var/www/miq/vmdb/app/models/ems_refresh/parsers/openstack.rb:9:in `ems_inv_to_hashes'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/openstack_refresher.rb:6:in `parse_inventory'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:20:in `block in refresh'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:8:in `each'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:8:in `refresh'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/base_refresher.rb:8:in `refresh'
/var/www/miq/vmdb/app/models/ems_refresh.rb:80:in `block in refresh'
/var/www/miq/vmdb/app/models/ems_refresh.rb:78:in `each'
/var/www/miq/vmdb/app/models/ems_refresh.rb:78:in `refresh'
/var/www/miq/vmdb/app/models/miq_queue.rb:356:in `block in deliver'
/opt/rh/ruby200/root/usr/share/ruby/timeout.rb:66:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:352:in `deliver'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:107:in `deliver_queue_message'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:135:in `deliver_message'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:152:in `block in do_work'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:146:in `loop'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:146:in `do_work'
/var/www/miq/vmdb/lib/workers/worker_base.rb:323:in `block in do_work_loop'
/var/www/miq/vmdb/lib/workers/worker_base.rb:320:in `loop'
/var/www/miq/vmdb/lib/workers/worker_base.rb:320:in `do_work_loop'




Version-Release number of selected component (if applicable):
---------------------
5.4.2


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Add a RHOS provider to CFME
2.
3.


Actual results:
--------------
RHOS provider refresh fails


Expected results:
----------------
RHOS provider refresh should succeed.

Additional info:
---------------
Comment 2 Nandini Chandra 2015-08-31 11:24:12 EDT
I see this issue with the QE RHOS 6 provider and not other RHOS providers.
Comment 4 Greg Blomquist 2015-09-03 10:15:27 EDT
This was a problem with the OpenStack Environment.  Someone added a new region to the OpenStack environment.

I had to delete two erroneous endpoints that were seemingly mistakenly added as well as an erroneous service.

That removed the extra Region.

As it stands, we don't actually support multiple regions in OpenStack, yet.

I'm closing this as "NOTABUG" since this was purely environmental.

If you see this come up again, please let me know and we can try to track down how these extra services and endpoints are getting added.

Note You need to log in before you can comment on or make changes to this bug.