Bug 1258095 - [abrt] viking: __memcpy_sse2_unaligned(): viking killed by SIGSEGV
[abrt] viking: __memcpy_sse2_unaligned(): viking killed by SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: viking (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:cfac4fa2972b2618f25566447a1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 21:33 EDT by Marcus
Modified: 2015-12-18 04:59 EST (History)
1 user (show)

See Also:
Fixed In Version: viking-1.6.1-1.fc23 viking-1.6.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 02:54:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (47.21 KB, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: core_backtrace (5.41 KB, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: dso_list (10.73 KB, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: environ (1.50 KB, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: maps (57.92 KB, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: mountinfo (3.73 KB, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: open_fds (1.13 KB, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: proc_pid_status (1005 bytes, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details
File: var_log_messages (290 bytes, text/plain)
2015-08-28 21:33 EDT, Marcus
no flags Details

  None (edit)
Description Marcus 2015-08-28 21:33:01 EDT
Description of problem:
 I had two map layers, one Bing on the bottom, One StreetCyclemap on top with alpha set at around 50%.
Just panning left/right make the sigsegv happen.
Can be reproduced intermittently.

Version-Release number of selected component:
viking-1.6-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        viking
crash_function: __memcpy_sse2_unaligned
executable:     /usr/bin/viking
global_pid:     8202
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __memcpy_sse2_unaligned at ../sysdeps/x86_64/multiarch/memcpy-sse2-unaligned.S:33
 #1 memcpy at /usr/include/bits/string3.h:53
 #2 _gdk_x11_convert_to_format at gdkdrawable-x11.c:1147
 #3 draw_with_images at gdkdrawable-x11.c:1321
 #4 gdk_x11_draw_pixbuf at gdkdrawable-x11.c:1520
 #5 vik_viewport_draw_pixbuf at vikviewport.c:1373
 #6 maps_layer_draw_section at vikmapslayer.c:1384
 #7 maps_layer_draw at vikmapslayer.c:1468
 #8 vik_aggregate_layer_draw at vikaggregatelayer.c:351
 #9 vik_layers_panel_draw_all at viklayerspanel.c:570
Comment 1 Marcus 2015-08-28 21:33:04 EDT
Created attachment 1068180 [details]
File: backtrace
Comment 2 Marcus 2015-08-28 21:33:05 EDT
Created attachment 1068181 [details]
File: cgroup
Comment 3 Marcus 2015-08-28 21:33:07 EDT
Created attachment 1068182 [details]
File: core_backtrace
Comment 4 Marcus 2015-08-28 21:33:08 EDT
Created attachment 1068183 [details]
File: dso_list
Comment 5 Marcus 2015-08-28 21:33:09 EDT
Created attachment 1068184 [details]
File: environ
Comment 6 Marcus 2015-08-28 21:33:11 EDT
Created attachment 1068185 [details]
File: limits
Comment 7 Marcus 2015-08-28 21:33:13 EDT
Created attachment 1068186 [details]
File: maps
Comment 8 Marcus 2015-08-28 21:33:14 EDT
Created attachment 1068187 [details]
File: mountinfo
Comment 9 Marcus 2015-08-28 21:33:15 EDT
Created attachment 1068188 [details]
File: namespaces
Comment 10 Marcus 2015-08-28 21:33:16 EDT
Created attachment 1068189 [details]
File: open_fds
Comment 11 Marcus 2015-08-28 21:33:18 EDT
Created attachment 1068190 [details]
File: proc_pid_status
Comment 12 Marcus 2015-08-28 21:33:19 EDT
Created attachment 1068191 [details]
File: var_log_messages
Comment 13 Fedora Update System 2015-11-25 04:39:19 EST
viking-1.6.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4f81292f22
Comment 14 Fedora Update System 2015-11-25 05:08:01 EST
viking-1.6.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-d775e43058
Comment 15 Fedora Update System 2015-11-25 06:38:27 EST
viking-1.6.1-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-264e3aa9ac
Comment 16 Fedora Update System 2015-11-25 20:21:43 EST
viking-1.6.1-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update viking'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-264e3aa9ac
Comment 17 Fedora Update System 2015-11-25 21:25:11 EST
viking-1.6.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update viking'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-d775e43058
Comment 18 Fedora Update System 2015-11-25 21:54:04 EST
viking-1.6.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update viking'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4f81292f22
Comment 19 Marcus 2015-12-13 18:01:02 EST
I have tested on F23 and all seems to be ok.
Thank you for fixing this.
Great product.
Comment 20 Fedora Update System 2015-12-18 02:54:26 EST
viking-1.6.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2015-12-18 04:59:52 EST
viking-1.6.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.