Bug 1258105 - open-vm-tools is too old for Fedora 23 on VMware Workstation 12
open-vm-tools is too old for Fedora 23 on VMware Workstation 12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: open-vm-tools (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravindra Kumar
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-29 01:57 EDT by Sebastian Bergmann
Modified: 2016-05-31 05:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: open-vm-tools-10.0.0-7.fc23 open-vm-tools-10.0.0-7.fc22 open-vm-tools-10.0.0-7.fc21 open-vm-tools-10.0.5-2.fc23 open-vm-tools-10.0.5-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-27 22:23:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec patch (2.03 KB, patch)
2015-09-30 16:50 EDT, Loïc Yhuel
no flags Details | Diff

  None (edit)
Description Sebastian Bergmann 2015-08-29 01:57:59 EDT
[root@localhost vmware-tools-distrib]# ./vmware-install.pl 
The installer has detected an existing installation of open-vm-tools on this 
system and will not attempt to remove and replace these user-space 
applications. It is recommended to use the open-vm-tools packages provided by 
the operating system. If you do not want to use the existing installation of 
open-vm-tools and attempt to install VMware Tools, you must uninstall the 
open-vm-tools packages and re-run this installer.
The packages that need to be removed are:
open-vm-tools
The installer will next check if there are any missing kernel drivers. Type yes
if you want to do this, otherwise type no [yes] 

For kernels >= 4.0.0, open-vm-tools need to be of version 10.0.0 or higher for 
VMware Host Guest Filessystem (vmhgfs) to function with VMware Tools. Please 
upgrade open-vm-tools and rerun this installer, or uninstall open-vm-tools. 
Alternatively, you can disable using the vmhgfs when VMware Tools are 
configured.

Enter yes to proceed. [no] 

Execution aborted.


[root@localhost vmware-tools-distrib]# dnf info open-vm-tools
Last metadata expiration check performed 0:46:34 ago on Sat Aug 29 07:07:15 2015.
Installed Packages
Name        : open-vm-tools
Arch        : x86_64
Epoch       : 0
Version     : 9.10.2
Release     : 1.fc23
Size        : 1.8 M
Repo        : @System
From repo   : fedora
Summary     : Open Virtual Machine Tools for virtual machines hosted on VMware
URL         : http://open-vm-tools.sourceforge.net/
License     : GPLv2
Description : The open-vm-tools project is an open source implementation of
            : VMware Tools. It is a suite of open source virtualization
            : utilities and drivers to improve the functionality, user
            : experience and administration of VMware virtual machines. This
            : package contains only the core user-space programs and libraries
            : of open-vm-tools.

Available Packages
Name        : open-vm-tools
Arch        : i686
Epoch       : 0
Version     : 9.10.2
Release     : 1.fc23
Size        : 598 k
Repo        : fedora
Summary     : Open Virtual Machine Tools for virtual machines hosted on VMware
URL         : http://open-vm-tools.sourceforge.net/
License     : GPLv2
Description : The open-vm-tools project is an open source implementation of
            : VMware Tools. It is a suite of open source virtualization
            : utilities and drivers to improve the functionality, user
            : experience and administration of VMware virtual machines. This
            : package contains only the core user-space programs and libraries
            : of open-vm-tools.
Comment 1 Loïc Yhuel 2015-09-30 16:50 EDT
Created attachment 1078822 [details]
spec patch

Here is how I built the 10.0.0-3000743 release on f23
Comment 2 Ravindra Kumar 2015-09-30 22:32:06 EDT
I'm on it already. I made the changes and it broke because of libsigc++ upgrade. Now that I have figured what is going on and your patch also confirms what I have found, I should have an update for testing today.

Thanks for the patch, but I have already checked in part of the changes.
Comment 3 Fedora Update System 2015-10-01 03:20:04 EDT
open-vm-tools-10.0.0-4.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-bcae3aae6b
Comment 4 Fedora Update System 2015-10-01 03:20:04 EDT
open-vm-tools-10.0.0-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-aa358c7ef8
Comment 5 Fedora Update System 2015-10-01 03:20:22 EDT
open-vm-tools-10.0.0-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f39cffcc60
Comment 6 Fedora Update System 2015-10-01 18:49:54 EDT
open-vm-tools-10.0.0-7.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f471d4afd9
Comment 7 Fedora Update System 2015-10-01 18:49:54 EDT
open-vm-tools-10.0.0-7.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ec288a2c3f
Comment 8 Fedora Update System 2015-10-01 18:50:01 EDT
open-vm-tools-10.0.0-7.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9d99df1e20
Comment 9 Ravindra Kumar 2015-10-02 21:35:26 EDT
Could somebody please provide some Karma to this update in F23 to go through? Thanks!
Comment 10 Fedora Update System 2015-10-03 21:36:38 EDT
open-vm-tools-10.0.0-7.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update open-vm-tools'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ec288a2c3f
Comment 11 Fedora Update System 2015-10-03 21:37:23 EDT
open-vm-tools-10.0.0-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update open-vm-tools'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-aa358c7ef8
Comment 12 Fedora Update System 2015-10-03 21:52:43 EDT
open-vm-tools-10.0.0-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update open-vm-tools'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9d99df1e20
Comment 13 Fedora Update System 2015-10-03 22:20:43 EDT
open-vm-tools-10.0.0-7.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update open-vm-tools'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f471d4afd9
Comment 14 Fedora Update System 2015-10-03 22:21:13 EDT
open-vm-tools-10.0.0-4.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update open-vm-tools'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-bcae3aae6b
Comment 15 Fedora Update System 2015-10-04 15:14:20 EDT
open-vm-tools-10.0.0-7.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2015-10-05 17:53:26 EDT
open-vm-tools-10.0.0-7.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-11-01 17:21:52 EST
open-vm-tools-10.0.0-7.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2016-05-25 15:13:22 EDT
open-vm-tools-10.0.5-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0bd6a38cad
Comment 19 Fedora Update System 2016-05-25 15:19:39 EDT
open-vm-tools-10.0.5-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-36485d53b0
Comment 20 Fedora Update System 2016-05-26 00:53:20 EDT
open-vm-tools-10.0.5-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-36485d53b0
Comment 21 Fedora Update System 2016-05-26 01:00:47 EDT
open-vm-tools-10.0.5-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0bd6a38cad
Comment 22 Fedora Update System 2016-05-27 22:23:25 EDT
open-vm-tools-10.0.5-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2016-05-31 05:21:12 EDT
open-vm-tools-10.0.5-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.