Bug 1258108 - [abrt] dnf: output.py:2230:_makefmt:ValueError: unsupported format character '-' (0x2d) at index 7
[abrt] dnf: output.py:2230:_makefmt:ValueError: unsupported format character ...
Status: CLOSED DUPLICATE of bug 1256531
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:40ada883652ae97b93cdc1de841...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-29 02:48 EDT by Shatadru Bandyopadhyay
Modified: 2015-09-01 08:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 08:27:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.16 KB, text/plain)
2015-08-29 02:48 EDT, Shatadru Bandyopadhyay
no flags Details
File: environ (2.67 KB, text/plain)
2015-08-29 02:48 EDT, Shatadru Bandyopadhyay
no flags Details

  None (edit)
Description Shatadru Bandyopadhyay 2015-08-29 02:48:31 EDT
Version-Release number of selected component:
dnf-1.1.0-2.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python -OO /bin/dnf reinstall a52dec aajohan-comfortaa-fonts aalib-libs abattis-cantarell-fonts abrt abrt-addon-ccpp abrt-addon-coredump-helper abrt-addon-kerneloops abrt-addon-pstoreoops abrt-addon-python abrt-addon-python3 abrt-addon-vmcore abrt-addon-xorg abrt-cli abrt-dbus abrt-desktop abrt-gui abrt-gui-libs abrt-java-connector abrt-libs abrt-plugin-bodhi abrt-python abrt-python3 abrt-retrace-client abrt-tui accountsservice accountsservice-libs acl AdobeReader_enu adobe-source-han-sans-cn-fonts adobe-source-han-sans-twhk-fonts adwaita-cursor-theme adwaita-gtk2-theme adwaita-icon-theme adwaita-qt4 adwaita-qt-common aircrack-ng akonadi alsa-lib alsa-plugins-pulseaudio alsa-utils amrnb amrwb anaconda anaconda-core anaconda-gui anaconda-tui anaconda-user-help anaconda-widgets apache-commons-collections apache-commons-daemon apache-commons-dbcp apache-commons-logging apache-commons-pool appmenu-qt appstream-data apr apr-devel apr-util apr-util-devel argyllcms artha aspell at atk atkmm atlas atmel-firmware at-spi2-atk at-spi2-core attica attr audit audit-libs audit-libs-python augeas-libs authconfig authconfig-gtk autoconf autocorr-en autofs autofs-debuginfo autogen-libopts automake avahi avahi-autoipd avahi-glib avahi-gobject avahi-libs avahi-ui-gtk3 b43-fwcutter b43-openfwwf babl baobab basesystem bash bash-completion bc beesu bijiben bind99-libs bind99-license bind-libs bind-libs-lite bind-license bind-utils binutils bjnplugin bleachbit bluez bluez-cups bluez-libs bonnie++ boost-date-time boost-iostreams boost-program-options boost-system boost-thread brasero-libs breeze-icon-theme bridge-utils brlapi brltty btrfs-progs bzip2 bzip2-libs cabextract caca-utils ca-certificates cagibi cairo cairo-gobject cairomm c-ares caribou caribou-gtk2-module caribou-gtk3-module cdparanoia-libs celt051 check checkpolicy checksysreport cheese cheese-libs chkconfig chrony cifs-utils clucene09-core clucene-contribs-lib clucene-core clutter clutter-gst2 clutter-gst3 clutter-gtk cogl colord colord-gtk colord-libs color-filesystem comps-extras conserver-client control-center control-center-filesystem coolkey coreutils corosync corosynclib cowsay cpio cracklib cracklib-dicts crash crda createrepo_c createrepo_c-libs cronie cronie-anacron crontabs crypto-policies cryptsetup cryptsetup-libs cryptsetup-python cups cups-client cups-filesystem cups-filters cups-filters-libs cups-libs cups-pk-helper curl cyrus-sasl cyrus-sasl-devel cyrus-sasl-gssapi cyrus-sasl-lib cyrus-sasl-md5 cyrus-sasl-plain cyrus-sasl-scram dbus dbus-glib dbus-libs dbusmenu-qt dbus-python dbus-x11 dconf dejavu-fonts-common dejavu-sans-fonts dejavu-sans-mono-fonts dejavu-serif-fonts deltarpm desktop-backgrounds-basic desktop-backgrounds-compat desktop-backgrounds-gnome desktop-file-utils device-mapper device-mapper-event device-mapper-event-libs device-mapper-libs device-mapper-multipath device-mapper-multipath-libs device-mapper-persistent-data dhcp-client dhcp-common dhcp-libs diffutils dleyna-connector-dbus dleyna-core dleyna-server dmidecode dmraid dmraid-events dnf dnf-automatic dnf-conf dnfdaemon dnf-langpacks dnf-plugins-core dnf-yum dnsmasq docbook-dtds docbook-style-xsl dos2unix dosfstools dotconf dracut dracut-config-rescue dracut-network driftnet drpm dsniff dtc dump e2fsprogs e2fsprogs-libs ebtables ecj ed efibootmgr efivar efivar-libs elfutils elfutils-default-yama-scope elfutils-libelf elfutils-libs elinks emacs-filesystem empathy enca enchant environment-modules eog epiphany-runtime espeak ethtool evince evince-browser-plugin evince-libs evince-nautilus evolution evolution-data-server evolution-ews evolution-help exempi exiv2-libs exo expat expat-devel f21-backgrounds-base f21-backgrounds-gnome f22-backgrounds-base f22-backgrounds-gnome faac faad2 faad2-libs farstream farstream02 fcoe-utils fedora-bookmarks fedora-logos fedora-logos-httpd fedora-productimg-workstation fedora-release fedora-release-notes fedora-release-workstation fedora-repos fedora-user-agent-chrome fedup fedy fedy-core fedy-plugins festival festival-freebsoft-utils festival-lib festival
dso_list:       python-dnf-1.1.0-2.fc22.noarch
executable:     /bin/dnf
kernel:         4.0.6-300.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
output.py:2230:_makefmt:ValueError: unsupported format character '-' (0x2d) at index 7

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dnf/yum/rpmtrans.py", line 415, in callback
    self._instProgress( bytes, total, h )
  File "/usr/lib/python2.7/site-packages/dnf/yum/rpmtrans.py", line 493, in _instProgress
    self.total_actions)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 2156, in progress
    percent, process, pkgname, wid1)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 2174, in _out_progress
    pkgname=pkgname, wid1=wid1)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 2230, in _makefmt
    bar = fmt_bar % (self.mark * int(marks * (percent / 100.0)), )
ValueError: unsupported format character '-' (0x2d) at index 7

Local variables in innermost frame:
ts_total: 4356L
wid1: 12
pkgname: u'protobuf-c-1.0.1-2.fc22.x86_64'
full_pnl: -9
percent: 0L
self: <dnf.cli.output.CliTransactionDisplay object at 0x7fa978a275d0>
fmt_done: u'%4.4s/%4.4s'
l: 4
ts_done: 670
width: u'-10.-10'
overhead: 30
pnl: 0
done: u' 670/4356'
marks: -10
fmt_bar: u'[%--10.-10s]'
progress: True
size: u'4.4'
Comment 1 Shatadru Bandyopadhyay 2015-08-29 02:48:36 EDT
Created attachment 1068213 [details]
File: backtrace
Comment 2 Shatadru Bandyopadhyay 2015-08-29 02:48:38 EDT
Created attachment 1068214 [details]
File: environ
Comment 3 Honza Silhan 2015-09-01 08:27:01 EDT

*** This bug has been marked as a duplicate of bug 1256531 ***

Note You need to log in before you can comment on or make changes to this bug.