Bug 1258113 - snapshot delete all command fails with --xml option.
snapshot delete all command fails with --xml option.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: rjoseph
: Triaged
Depends On: 1161416 1257533
Blocks: 1245077
  Show dependency treegraph
 
Reported: 2015-08-29 05:49 EDT by Avra Sengupta
Modified: 2015-10-14 06:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1257533
Environment:
Last Closed: 2015-10-14 06:30:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avra Sengupta 2015-08-29 05:49:35 EDT
+++ This bug was initially created as a clone of Bug #1257533 +++

+++ This bug was initially created as a clone of Bug #1161416 +++

Description of problem:
gluster snapshot delete all command fails when invoked with --xml option.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.gluster snapshot delete all --xml
2.
3.

Actual results:
when above command is executed it fails with message "Snapshot command failed"

Expected results:
command should provide proper xml output.

Additional info:

--- Additional comment from Darshan on 2015-01-23 02:15:46 EST ---

Even "gluster snapshot delete volume <volume-name> --xml" command fails

--- Additional comment from Anand Avati on 2015-08-27 05:53:01 EDT ---

REVIEW: http://review.gluster.org/12027 (gluster/cli: snapshot delete all does not work with xml) posted (#1) for review on master by Rajesh Joseph (rjoseph@redhat.com)

--- Additional comment from Anand Avati on 2015-08-29 01:11:04 EDT ---

COMMIT: http://review.gluster.org/12027 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit fd47635a4ffab621a2357c99cd1edd0482940bd5
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Wed Aug 26 08:28:59 2015 +0530

    gluster/cli: snapshot delete all does not work with xml
    
    Problem: snapshot delete all command fails with --xml option
    Fix: Provided xml support for delete all command
    
    Change-Id: I77cad131473a9160e188c783f442b6a38a37f758
    BUG: 1257533
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/12027
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
Comment 1 Avra Sengupta 2015-08-29 05:54:44 EDT
Release 3.7 patch at http://review.gluster.org/#/c/12042/
Comment 2 Anand Avati 2015-09-01 02:41:03 EDT
COMMIT: http://review.gluster.org/12042 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit eb33931e4f7f57af87e307d36baba5084cd97da8
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Wed Aug 26 08:28:59 2015 +0530

    gluster/cli: snapshot delete all does not work with xml
    
        Backport of http://review.gluster.org/#/c/12027/
    
    Problem: snapshot delete all command fails with --xml option
    Fix: Provided xml support for delete all command
    
    Change-Id: I77cad131473a9160e188c783f442b6a38a37f758
    BUG: 1258113
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/12027
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    (cherry picked from commit fd47635a4ffab621a2357c99cd1edd0482940bd5)
    Reviewed-on: http://review.gluster.org/12042
Comment 3 Pranith Kumar K 2015-10-14 06:30:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 4 Pranith Kumar K 2015-10-14 06:38:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.