Bug 1258124 - Java 8 usage for tomcat
Java 8 usage for tomcat
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Timothy Williams
Yan Du
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-29 07:43 EDT by mike
Modified: 2015-09-09 13:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 20741, Cartridge Specification Guide-null-1.0 Build Date: 16-09-2014 11:20:45 Topic ID: 20912-592391 [Latest]
Last Closed: 2015-09-09 13:24:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mike 2015-08-29 07:43:17 EDT
Title: Custom Cartridge Environment Variables

Describe the issue:
Hi, I am trying to use java 8 for tomcat but with no luck for now.
As I see it defined here /var/lib/openshift/55e15a0b89f5cf10b70000b7/jbossews/env/OPENSHIFT_JBOSSEWS_PATH_ELEMENT, JAVA_HOME
but I am unable to change it to
/etc/alternatives/java_sdk_1.8.0/bin
Is it possible to change it or can you point to corresponded page, which explaine how to do it.

On this page 
https://access.redhat.com/documentation/en-US/OpenShift_Online/2.0/html/Cartridge_Specification_Guide/Examples_of_Cartridge_Variables1.html
I can't add it by myself as dir owner - root. Maybe it is possible to switch my user as owner?

Suggestions for improvement:


Additional information:
Comment 2 Timothy Williams 2015-09-09 13:24:29 EDT
Java 8 is not supported for use with Tomcat 7, so it is not offered. See the below article on the Jbossews-2.0 (Tomcat 7) supported configurations:

  https://access.redhat.com/articles/258223

If Java 8 is required, a Tomcat 8 cartridge can be created from the DIY cartridge. There have been many articles written that explain how to do this that a little googling will reveal, such as the below:

  https://blog.openshift.com/how-to-run-apache-tomcat-8-on-openshift/

There are also examples created by community members, one example below:

 https://github.com/shekhargulati/openshift-tomcat8-quickstart

Closing this WONTFIX since there are no plans to create an officially supported Jbossews-3.0 (Tomcat 8) cartridge in the near future.

Note You need to log in before you can comment on or make changes to this bug.