Bug 1258195 - [LOG] redundant invocation of RemoveAllVmCinderDisksCommand
[LOG] redundant invocation of RemoveAllVmCinderDisksCommand
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.6.0
Unspecified Unspecified
low Severity low (vote)
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Daniel Erez
Ori Gofen
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 03:43 EDT by Daniel Erez
Modified: 2016-03-10 10:18 EST (History)
8 users (show)

See Also:
Fixed In Version: 3.6.0-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:48:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45477 master MERGED core: invoke RemoveAllVmCinderDisks only when relevant Never
oVirt gerrit 45560 ovirt-engine-3.6 MERGED core: invoke RemoveAllVmCinderDisks only when relevant Never

  None (edit)
Description Daniel Erez 2015-08-30 03:43:19 EDT
Description of problem:
Upon removing a VM with non-Cinder disks, RemoveAllVmCinderDisksCommand is redundantly being invoked. 

Steps to Reproduce:
1. Create a VM
2. Add a Disk (Image/LUN)
3. Remove the VM

Actual results:
RemoveAllVmCinderDisksCommand is invoked.

Expected results:
RemoveAllVmCinderDisksCommand should be invoked only when CinderDisks exist.
Comment 1 Ori Gofen 2015-11-17 08:39:41 EST
Verified on rhevm-3.6-0.2
Comment 2 Sandro Bonazzola 2015-11-27 02:48:05 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.