Bug 1258198 - [SR-IOV] - Edit vNIC profile > 'QoS' should be disabled if 'passthrough' is checked and used by VM
[SR-IOV] - Edit vNIC profile > 'QoS' should be disabled if 'passthrough' is c...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity medium
: ovirt-3.6.2
: ---
Assigned To: Alona Kaplan
Michael Burman
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 04:38 EDT by Michael Burman
Modified: 2016-02-10 14:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:56:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Burman 2015-08-30 04:38:22 EDT
Description of problem:
[SR-IOV] - Edit vNIC profile > 'QoS' should be disabled if 'passthrough' is checked and used by VM.

- On new vNIC profile dialog, QoS and Port mirroring are disabled when checking 'passthrough' check box , the same should be for the edit vNIC profile dialog if 'passthrough' is checked and the profile is used by VM. 
Today on the edit vNIC profile dialog the 'QoS' is not cleaned and the 'QoS' is editable and can be updated.

Version-Release number of selected component (if applicable):
3.6.0-0.12.master.el6

How reproducible:
100

Steps to Reproduce:
1. Create network with 'passthrough' profile(QoS and Port mirroring are disabled) and add to VM
2. Create QoS(VM network) via DC
3. Edit vNIC profile with network QoS

Actual results:
It is possible to update vNICs profile with network QoS when 'passthrough' is checked and profile is used by VM. QoS is not cleaned when 'passthrough' is checked in the edit dialog.

Expected results:
QoS should be disabled on the edit vNIC profile dialog if 'passthrouhg' is checked and used by VM
Comment 1 Alona Kaplan 2015-11-19 03:06:57 EST
It works for me. Can you please check if it is still reproducible?
Comment 2 Michael Burman 2015-11-19 03:56:22 EST
Can't reproduce any more on - 3.6.0.3-0.1.el6

Note You need to log in before you can comment on or make changes to this bug.