Bug 1258210 - SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'mmap_zero' accesses on the memprotect Unknown.
SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'mmap_zer...
Status: CLOSED DUPLICATE of bug 859625
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c33ae18f1c9fab33802eeef9aa6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 06:14 EDT by Otto J. Makela
Modified: 2015-08-31 08:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 08:15:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Otto J. Makela 2015-08-30 06:14:49 EDT
Description of problem:
Starting Chrome normally.
SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'mmap_zero' accesses on the memprotect Unknown.

*****  Plugin mmap_zero (53.1 confidence) suggests   *************************

If you do not think /opt/google/chrome/nacl_helper_bootstrap should need to mmap low memory in the kernel.
Then you may be under attack by a hacker, this is a very dangerous access.
Do
contact your security administrator and report this issue.

*****  Plugin catchall_boolean (42.6 confidence) suggests   ******************

If you want to allow mmap to low allowed
Then you must tell SELinux about this by enabling the 'mmap_low_allowed' boolean.
You can read 'None' man page for more details.
Do
setsebool -P mmap_low_allowed 1

*****  Plugin catchall (5.76 confidence) suggests   **************************

If you believe that nacl_helper_bootstrap should be allowed mmap_zero access on the Unknown memprotect by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep nacl_helper_boo /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                Unknown [ memprotect ]
Source                        nacl_helper_boo
Source Path                   /opt/google/chrome/nacl_helper_bootstrap
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           google-chrome-stable-44.0.2403.157-1.i386
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.12.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.1.5-200.fc22.i686 #1 SMP Tue Aug
                              11 00:11:41 UTC 2015 i686 i686
Alert Count                   23
First Seen                    2015-08-28 22:13:11 EEST
Last Seen                     2015-08-30 13:00:28 EEST
Local ID                      31086ff6-d011-4a59-8e0c-c20e9b1a59ef

Raw Audit Messages
type=AVC msg=audit(1440928828.40:1072): avc:  denied  { mmap_zero } for  pid=25507 comm="nacl_helper_boo" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=memprotect permissive=0


type=SYSCALL msg=audit(1440928828.40:1072): arch=i386 syscall=mmap2 success=no exit=EACCES a0=f000 a1=1000 a2=0 a3=4032 items=0 ppid=25505 pid=25507 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=tty2 ses=3 comm=nacl_helper_boo exe=/opt/google/chrome/nacl_helper_bootstrap subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: nacl_helper_boo,unconfined_t,unconfined_t,memprotect,mmap_zero

Version-Release number of selected component:
selinux-policy-3.13.1-128.12.fc22.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.1.5-200.fc22.i686
type:           libreport

Potential duplicate: bug 859625
Comment 1 Miroslav Grepl 2015-08-31 08:15:53 EDT

*** This bug has been marked as a duplicate of bug 859625 ***

Note You need to log in before you can comment on or make changes to this bug.