Bug 1258234 - Deadlock in user sync causes failures in collections and aggregation after creating fk to user details.
Deadlock in user sync causes failures in collections and aggregation after cr...
Status: CLOSED WONTFIX
Product: ovirt-engine-dwh
Classification: oVirt
Component: General (Show other bugs)
---
x86_64 Linux
unspecified Severity high (vote)
: ovirt-4.0.0-beta
: ---
Assigned To: Shirly Radco
Lukas Svaty
:
Depends On: 1254003
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 08:59 EDT by Yaniv Lavi (Dary)
Modified: 2016-05-19 05:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1254003
Environment:
Last Closed: 2016-05-19 05:37:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44884 None None None Never
oVirt gerrit 44885 None None None Never

  None (edit)
Description Yaniv Lavi (Dary) 2015-08-30 08:59:48 EDT
+++ This bug was initially created as a clone of Bug #1254003 +++

Description of problem:
Deadlock in user sync causes failures in collections and aggregation. The users details sync is done every minute it lock the row for update, once a hour the hourly aggregation tries to sync VM data containing users foreign key which causes deadlock due to wait on the users table update.

See Thread about this issue:
http://stackoverflow.com/questions/18536147/deadlock-involving-foreign-key-constraint

and fix in 9.3 for this:
http://michael.otacoo.com/postgresql-2/postgres-9-3-feature-highlight-for-key-share-and-for-no-key-update/

Version-Release number of selected component (if applicable):
3.5.0

How reproducible:
always

Steps to Reproduce:
1. add many users to engine.
2. use users on some vm.
3. waiting a few hours for aggregation to start

Actual results:
Deadlock between aggregation (due to foreign keys) and collection.

Expected results:
Should not deadlock.

--- Additional comment from Yaniv Dary on 2015-08-16 09:45:01 EDT ---



--- Additional comment from Yaniv Dary on 2015-08-16 09:53:16 EDT ---



--- Additional comment from Yaniv Dary on 2015-08-16 10:42:11 EDT ---

To unblock 3.5 users that might hit this, we will remove the foreign key completely. For 3.6 we will try to find a better way to fix this, maybe by reducing the amount of updates done in each time.
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:55:44 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Lavi (Dary) 2015-10-29 08:32:34 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Sandro Bonazzola 2016-05-02 06:01:13 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 4 Shirly Radco 2016-05-19 05:37:31 EDT
We resolved this by removing the db enforcement.

Note You need to log in before you can comment on or make changes to this bug.