Bug 1258243 - Install fails when Host name has capital letter assigned to it
Install fails when Host name has capital letter assigned to it
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Andrew Butcher
Ma xiaoqiang
:
: 1258074 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 09:48 EDT by Ryan Howe
Modified: 2015-12-02 03:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1396350 (view as bug list)
Environment:
Last Closed: 2015-11-20 10:41:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-08-30 09:48:06 EDT
Description of problem: The ansible and quick install fail when the HostName is manually defined containing a Capital Letter.

- The install takes the env variable with the capital letter and passes it through with the command #oc get node <openshift_hostnamem> 

the anisable installer hase this as <openshift_nodes> 

Kubernetes converts the names of the nodes to lower case and will not recognize a node name with a capital letter. Example: 

HostName:   Node1.example.com 
Kubernetes names the node:    node1.example.com 

Ansible install checks on the node registration with the following: 

#oc get node Node1.example.com 


The installer in turn fails. 




Version-Release number of selected component (if applicable): v3.0.1


How reproducible:
100%
Quick and Advanced 

Steps to Reproduce:
1.  Spin up a new vm follow the docs to get it ready
2.  Edit your ansible host file with the names of the hosts using capital letters. Also manual define the variables openshift_hostname openshift_public_hostname 
3.  Run the Ansible installer 

Actual results:

Installer fails to register nodes, stops before the SDN is configured

Expected results:

Installer completes, converts the capital letters to lower case when running kubernetes commands to check nodes. 

Additional info:

Ansible Code that fails:
https://github.com/openshift/openshift-ansible/blob/16175aa7db9073ccc8173efea752a66f3b4a27c2/roles/openshift_manage_node/tasks/main.yml#L1-L8

Work around: 
Change all names and variables in /etc/ansible/hosts to lower case
Comment 2 Jason DeTiberus 2015-08-31 14:45:13 EDT
PR: https://github.com/openshift/openshift-ansible/pull/540
Comment 4 Dan Winship 2015-09-10 11:22:56 EDT
*** Bug 1258074 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Butcher 2015-09-30 15:34:17 EDT
Moved the original PR since Jason is out.

PR: https://github.com/openshift/openshift-ansible/pull/635
Comment 8 Ma xiaoqiang 2015-10-09 01:57:25 EDT
After installation, QE create nodejs-example.

The app is create successfully
QE can access the app url.
QE can login the webconsole.

Note You need to log in before you can comment on or make changes to this bug.