Bug 1258245 - [VM Pools][REST-API] vmpool entity in API has no type attribute while one exist in UI
[VM Pools][REST-API] vmpool entity in API has no type attribute while one exi...
Status: CLOSED DUPLICATE of bug 1244841
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Hernández
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 09:53 EDT by sefi litmanovich
Modified: 2015-08-31 02:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 02:39:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sefi litmanovich 2015-08-30 09:53:45 EDT
Description of problem:

In the webadmin one can set the type of pool to either manual or automatic.
In the API a vmpool entity doesn't have an attribute type and therefore a manual vm pool cannot be created via API (the default is automatic).

Version-Release number of selected component (if applicable):

rhevm-3.6.0-0.12.master.el6.noarch

How reproducible:
always.

Steps to Reproduce:
1. open new vm pool in UI see there is a type menu where you can choose between manual and automatic vm pool.
2. In documentation and in API you can see there's no type attribute for vm pool
Comment 1 Omer Frenkel 2015-08-31 02:39:52 EDT

*** This bug has been marked as a duplicate of bug 1244841 ***

Note You need to log in before you can comment on or make changes to this bug.