Bug 1258299 - Many cases fail when run libvirt-cim test with sblim-sfcb server
Many cases fail when run libvirt-cim test with sblim-sfcb server
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt-cim (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: John Ferlan
Jingjing Shao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 22:41 EDT by Shanzhi Yu
Modified: 2017-03-25 09:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-25 09:27:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shanzhi Yu 2015-08-30 22:41:32 EDT
Description of problem:
Many cases fail when run libvirt-cim test with sblim-sfcb server

Version-Release number of selected component (if applicable):


# uname -r && rpm -q selinux-policy libvirt-cim tog-pegasus sblim-sfcb
3.10.0-308.el7.x86_64
selinux-policy-3.13.1-45.el7.noarch
libvirt-cim-0.6.3-19.el7.x86_64
tog-pegasus-2.14.1-2.el7.x86_64
sblim-sfcb-1.3.16-12.el7_0.x86_64

How reproducible:
100%

Steps to Reproduce:

1. start sblim-sfcb

# service sblim-sfcb status
Redirecting to /bin/systemctl status  sblim-sfcb.service
● sblim-sfcb.service - Small Footprint CIM Broker Service
   Loaded: loaded (/usr/lib/systemd/system/sblim-sfcb.service; disabled;
vendor preset: disabled)
   Active: active (running) since Fri 2015-08-28 19:17:44 CST; 1s ago
 Main PID: 27298 (sfcbd)
   CGroup: /system.slice/sblim-sfcb.service
           ├─27298 /usr/sbin/sfcbd
           ├─27299 /usr/sbin/sfcbd
           ├─27301 /usr/sbin/sfcbd
           └─27302 /usr/sbin/sfcbd

2. run test

# CIM_NS=root/virt CIM_USER=root CIM_PASS=redhat ./runtests libvirt-cim
-v KVM `hostname`
Starting test suite: libvirt-cim

Testing KVM hypervisor
--------------------------------------------------------------------
AllocationCapabilities - 01_enum.py: PASS
--------------------------------------------------------------------
AllocationCapabilities - 02_alloccap_gi_errs.py: PASS
--------------------------------------------------------------------
ComputerSystem - 01_enum.py: PASS
---------------------------------------------------------------
......



--------------------------------------------------------------------
VirtualSystemManagementService - 11_define_memrasdunits.py: FAIL
ERROR         - get_default_rasds() returned None
Provider not found or not loadable

FilterList - 03_create.py: FAIL
ERROR         - Unable to get NetworkPort instance name for
'cimtest-filterlist-domain' domain
ERROR         - Caught exception: (6, u'Provider not found or not loadable')
--------------------------------------------------------------------
...

Actual results:


Expected results:


Additional info:

It work well when I run libvirt-cim test with tog-pegasus
Comment 1 John Ferlan 2015-08-31 07:49:41 EDT
As I pointed out in email:


>
> I don't have an sblim-sfcb config available. I think I've had other
> problems with it in the past attempting to configure. I do have a faint
> recollection that in there were changes in the tog-pegasus installation
> with respect to where the provider was installed/advertised. Ah yes, see
> the following upstream commit:
>
> http://libvirt.org/git/?p=libvirt-cim.git;a=commit;h=a8cfd7dc6a4f173c764f02688ff0c8aec00ecec2
>
> Given the "age" of sblim-sfcb-1.3, it could be that there's some sort of
> configuration issue with the older sblim-sfcb which hasn't kept up.
> Since I saw "7_0" in the rpm name, it made me wonder exactly what that
> meant...  If I Google sblim-sfcb, I find references that indicate 1.3 is
> in maintenance, but there is a 1.4. I have no idea what the differences
> are since I don't keep "up to date" on CIM servers. The last time I
> touched libvirt-cim code was over a year ago.  But if I had to guess,
> 1.3 doesn't use "root/interop".
>
> You could generate a libvirt bz, but it should be a low/zero priority,
> and be on the RHEL-7.3 list. Although, I think the real solution is to
> find whomever owns the sblim-sfcb package and find out why it hasn't
> been updated. Certainly the pegasus-2.14 is beyond the 2.12-5 mentioned
> in the commit message of my libvirt-cim change.  FWIW, this was one of
> the reasons I think I pushed for an update to libvirt-cim.
>
Comment 7 John Ferlan 2016-06-22 11:05:12 EDT
Move to consideration for 7.4
Comment 8 John Ferlan 2017-03-25 09:27:19 EDT
No sense dragging this out any longer. There's been no libvirt-cim activity and so just closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.