Bug 1258341 - Disperse volume: single file creation is generating many log messages
Disperse volume: single file creation is generating many log messages
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: disperse (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
Bhaskarakiran
: ZStream
Depends On: 1248941
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 02:44 EDT by Bhaskarakiran
Modified: 2016-11-23 18:11 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 00:34:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bhaskarakiran 2015-08-31 02:44:57 EDT
Description of problem:
=======================

Creating a single file on a disperse volume is logging many messages. Doing a single  linux untar alone is increasing the log file by more than 300MB

[2015-08-31 06:21:21.257170]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-0: remote operation failed [No data available]
[2015-08-31 06:21:21.257174]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-2: remote operation failed [No data available]
[2015-08-31 06:21:21.257406]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-4: remote operation failed [No data available]
[2015-08-31 06:21:21.257418]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-1: remote operation failed [No data available]
[2015-08-31 06:21:21.257510]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-7: remote operation failed [No data available]
[2015-08-31 06:21:21.257551]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-3: remote operation failed [No data available]
[2015-08-31 06:21:21.257560]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-5: remote operation failed [No data available]
[2015-08-31 06:21:21.257642]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-8: remote operation failed [No data available]
[2015-08-31 06:21:21.257671]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-6: remote operation failed [No data available]
[2015-08-31 06:21:21.257694]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-9: remote operation failed [No data available]
[2015-08-31 06:21:21.257731]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-10: remote operation failed [No data available]
[2015-08-31 06:21:21.257741]  [MSGID: 114031] [client-rpc-fops.c:1298:client3_3_removexattr_cbk] 13-vol1-client-11: remote operation failed [No data available]
[2015-08-31 06:21:21.257798] W [fuse-bridge.c:1263:fuse_err_cbk] 0-glusterfs-fuse: 2803533: REMOVEXATTR() /file => -1 (No data available)


Version-Release number of selected component (if applicable):
=============================================================
3.7.1-13

How reproducible:
=================
100%


Steps to Reproduce:
1. Create a distributed disperse volume 2x*8+4)
2. Fuse mount on the client
3. Linux untar and check the fuse log on the client.

Actual results:
===============
Creating many log messages for 1 create operation


Expected results:
=================
Should log only the message related to create

Additional info:
================
sosreport of client will be attached.
Comment 3 SATHEESARAN 2015-09-02 04:23:49 EDT
This issue seemed to be generic and not specific to disperse.
There is a relevant upstream bug for this issue - refer https://bugzilla.redhat.com/show_bug.cgi?id=1248941
Comment 7 Bhaskarakiran 2015-12-22 05:02:52 EST
Checked on 3.7.5-12 and have not seen the issue. Marking this as fixed.
Comment 9 errata-xmlrpc 2016-03-01 00:34:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.