This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1258374 - [abrt] lirc-config: subprocess.py:424:<module>:AttributeError: 'module' object has no attribute 'SelectSelector'
[abrt] lirc-config: subprocess.py:424:<module>:AttributeError: 'module' objec...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lirc (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alec Leamas
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f8ae60c0389e66b8f3dd7ca4977...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 04:47 EDT by Artem
Modified: 2015-09-19 14:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.9.3-5.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-19 14:55:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (19.97 KB, text/plain)
2015-08-31 04:47 EDT, Artem
no flags Details
File: environ (3.43 KB, text/plain)
2015-08-31 04:47 EDT, Artem
no flags Details

  None (edit)
Description Artem 2015-08-31 04:47:30 EDT
Description of problem:
simply started lirc-setup tool

Version-Release number of selected component:
lirc-config-0.9.2a-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        python3 /bin/lirc-setup
executable:     /bin/lirc-setup
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
#1 <module> in /usr/lib64/python3.4/subprocess.py:424
#2 <module> in /usr/lib/python3.4/site-packages/lirc/mvc_model.py:14
#3 <module> in /usr/lib/python3.4/site-packages/lirc/mvc_control.py:9
#4 <module> in /bin/lirc-setup:10
Comment 1 Artem 2015-08-31 04:47:33 EDT
Created attachment 1068540 [details]
File: backtrace
Comment 2 Artem 2015-08-31 04:47:34 EDT
Created attachment 1068541 [details]
File: environ
Comment 3 Fedora Update System 2015-09-07 08:39:33 EDT
lirc-0.9.3-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15270
Comment 4 Fedora Update System 2015-09-07 14:20:04 EDT
lirc-0.9.3-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update lirc'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15270
Comment 5 Artem 2015-09-08 02:58:14 EDT
Is it possible to get a fix in f22?
Comment 6 Alec Leamas 2015-09-08 03:46:34 EDT
The ultimate plane is to push 0.9.3 also to f22. However, I hesitate a little until the dust has settled.

For now, there is a 0.9.3-0.4pre3 release at the LIRC 0.9.3 preview COPR at https://copr.fedoraproject.org/coprs/leamas/lirc-0.9.3preview . That pre-release is actually the same as 0.9.3-4 on f23. Feedback is more than welcome, preferably at the upstream tracker at https://sourceforge.net/p/lirc/tickets/
Comment 7 Fedora Update System 2015-09-09 10:24:29 EDT
lirc-0.9.3-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15465
Comment 8 Fedora Update System 2015-09-10 01:51:26 EDT
lirc-0.9.3-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update lirc'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15465
Comment 9 Fedora Update System 2015-09-19 14:55:14 EDT
lirc-0.9.3-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.