Bug 1258404 - Faulty SMTP configuration results in error: "getaddrinfo: Name or service not known" when syncing repos
Faulty SMTP configuration results in error: "getaddrinfo: Name or service not...
Status: CLOSED DUPLICATE of bug 1261068
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin (Show other bugs)
6.1.0
All Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 05:55 EDT by Ludmila Ondrackova
Modified: 2015-11-16 16:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 07:42:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ludmila Ondrackova 2015-08-31 05:55:57 EDT
Description of problem:
When trying to sync repos, 
Sync Status is "Sync incomplete"
Clicking on the task shows this error:
"getaddrinfo: Name or service not known"

Version-Release number of selected component (if applicable):
Satellite 6.1

How reproducible:
always

Steps to Reproduce:
1. enter faulty SMTP configuration for notifications
2. try to sync the repos
3. fails with error: "getaddrinfo: Name or service not known"

Actual results:
Sync fails when the SMTP configuration for notifications is not set correctly

Expected results:
Sync should still complete even if the SMTP configuration for notifications is not set correctly
The error message should be a little bit more obvious and point to the faulty SMTP configuration

Additional info:
Comment 2 Brad Buckingham 2015-10-16 07:42:28 EDT

*** This bug has been marked as a duplicate of bug 1261068 ***

Note You need to log in before you can comment on or make changes to this bug.