Bug 125846 - Xchat menu entry should be changed
Xchat menu entry should be changed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Reed
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-06-12 06:46 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 17:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-06-12 06:46:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
The xchat menu entry is not compliant with the GNOME HIG.
Please change it to contain the program name, for example:

Xchat IRC Client

Version-Release number of selected component (if applicable):
xchat-2.0.7-5

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:
Comment 1 Ivan Gyurdiev 2004-06-13 16:03:59 EDT
Relevant:

Gnome Icons, Gnome/KDE Menus need improvement

on fedora-devel
Comment 2 Bryan W Clark 2004-06-15 15:13:05 EDT
in the .desktop file there should be a Name and GenericName entry,
XChat needs to fix the Name entry.

According to the HIG it would look like this:

Name=XChat IRC Client
GenericName=IRC Client
Comment 3 Ivan Gyurdiev 2004-06-15 15:56:56 EDT
It was suggested that the displayed entry be generated from both the
Name and the GenericName, which makes sense to me. See the thread on
fedora-devel listed above (Gnome..)

 
Comment 4 Ivan Gyurdiev 2004-06-15 16:00:13 EDT
Ah you seem to have changed the HIG.. 

Well... is this final as far as changes go? 

Maybe you should followup on the fedora-devel thread saying so...



Comment 5 Bryan W Clark 2004-06-15 16:25:26 EDT
hm, I'll get on the fedora-devel list, thanks.

Displayed names can be generated for the English language, but cannot
in many other languages, the syntax and grammar rules are different. 
You can't just cat the two together and say 'ok, that's how they do it
in German too!'

Yes, the HIG was updated because there was no section reflecting the
differences between generic and proper names in menu items and how
they are constructed.

Your changes are still valid for each of the bugs, the Name field is
incorrect as it has just been a copy of the GenericName field.
Comment 6 Seth Nickell 2004-06-16 12:25:56 EDT
In any case it should be "XChat IRC" not "XChat IRC Client".
Comment 8 Bryan W Clark 2004-07-07 02:35:15 EDT
Did I really use XChat IRC Client in the HIG?  I'll update the HIG to
reflect this.

Lets make this name simply "IRC" since it's our default IRC client. 
It's not like there should be confusion over whether this desktop
entry could start an IRC server instead of a client.

so 
  Name=IRC
  GenericName=IRC

For an explanation of why the Name is the same as the GenericName and
neither has the application name see bug 125848
Comment 9 Daniel Reed 2004-08-17 17:17:30 EDT
All localized Name and GenericName entries have been replaced with one
generic Name=IRC and GenericName=IRC.
Comment 10 Mephisto 2005-03-27 11:36:07 EST
"Lets make this name simply "IRC" since it's our default IRC client. 
It's not like there should be confusion over whether this desktop
entry could start an IRC server instead of a client."

I really think the program's name should be included. It's really inconsistent
if most applications have the program name in their menu entry and some
applications don't. I don't like how they changed XMMS to "Audio Player" either,
or Gaim to "IM". You dont call Firefox just "Web browser" either. A desktop
entry called "IRC" could launch something else then Xchat too, like KVirc or
Irssi. With Xchat it might not be really confusing, cause its the only client
thats installed by default, but i remember myself looking for XMMS, wondering
why it didn't have menu item, only to find out its changed to "Audio Player"
instead. grrr.
Comment 11 Ivan Gyurdiev 2005-03-27 12:09:35 EST
I think the gnome people decided to include the program name only if it's a
non-default app. Here "default" is defined as the one that's used by default in
GNOME, though that might not be the case for Fedora, which changes some of the
defaults. That way the default audio player is called "Audio Player", 
and if you know enough to install a second one, that one gets a program name.
Therefore it's not inconsistent. I didn't like it at first either, but that's
what was decided, and I don't care anymore personally.

Note You need to log in before you can comment on or make changes to this bug.