Bug 1258462 - Tabs listed thrice once gluster-monitoring-uiplugins installed
Summary: Tabs listed thrice once gluster-monitoring-uiplugins installed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-3.6.2
: 3.6.2
Assignee: Vojtech Szocs
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2015-08-31 12:57 UTC by Sahina Bose
Modified: 2016-03-11 07:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-11 07:21:52 UTC
oVirt Team: UX
sabose: ovirt-3.6.z?
ylavi: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
UI with tabs (364.94 KB, image/png)
2015-08-31 12:57 UTC, Sahina Bose
no flags Details
Test UI plugin that adds 3 new main tabs (530 bytes, application/x-gzip)
2015-12-15 19:25 UTC, Vojtech Szocs
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 50550 master MERGED webadmin: Fix ScrollableTabBarView.removeTabWidget 2015-12-16 16:13:06 UTC
oVirt gerrit 50650 ovirt-engine-3.6 MERGED webadmin: Fix ScrollableTabBarView.removeTabWidget 2015-12-22 08:34:35 UTC
Red Hat Bugzilla 1292375 None None None Never

Internal Links: 1292375

Description Sahina Bose 2015-08-31 12:57:14 UTC
Created attachment 1068639 [details]
UI with tabs

Description of problem:

The tabs are listed thrice once the gluster-monitoring-uiplugin is installed. Attached is the screenshot

Version-Release number of selected component (if applicable):


How reproducible:

Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 10:55:39 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Sandro Bonazzola 2015-10-26 12:46:43 UTC
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high

Comment 6 Sandro Bonazzola 2015-11-05 08:22:19 UTC
oVirt 3.6.0 has been released on November 4th, re-targeting to 4.0 since this bug has been marked with severity < high

Comment 7 Red Hat Bugzilla Rules Engine 2015-11-16 14:07:54 UTC
This bug is flagged for 3.6, yet the milestone is for 4.0 version, therefore the milestone has been reset.
Please set the correct milestone or add the flag.

Comment 8 Ramesh N 2015-12-09 10:38:01 UTC
Seems like some thing wrong with the way how we add new tabs through UI Plugin. When ever a new tab is added using UI Plugin, all the entries in the drop down is repeated once. So if we add 3 tabs then same list will be repeated 3 times ( excluding the default one time). 


RedrawDynamicTabContainerEvent is fired  whenever a new tab is added. We are removing all the existing tabs as part of this event and redrawing the same. But it fails to remove the entries from dropdown list. 


ScrollableTabBarView.removeTabWidget() tries to remove the widget from dropdownPandel by calling dropdownPanel.remove(listWidget). But it fails to remove and returns false. 

May be Vojtech can help he to fine the root cause here.

Comment 9 Red Hat Bugzilla Rules Engine 2015-12-11 02:19:17 UTC
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.

Comment 10 Vojtech Szocs 2015-12-15 18:04:42 UTC
Seems like UI infra issue.

I'll write sample UI plugin that adds 3 main tabs to reproduce and try to fix this.

Comment 11 Vojtech Szocs 2015-12-15 19:11:50 UTC
(In reply to Ramesh N from comment #8)
> ScrollableTabBarView.removeTabWidget() tries to remove the widget from
> dropdownPandel by calling dropdownPanel.remove(listWidget). But it fails to
> remove and returns false. 

Exactly! We're trying to remove wrong "listWidget" :-) I'm going to fix that.

Comment 12 Vojtech Szocs 2015-12-15 19:25:28 UTC
Created attachment 1106138 [details]
Test UI plugin that adds 3 new main tabs

Comment 13 Vojtech Szocs 2015-12-15 19:26:44 UTC
Attached test UI plugin (see comment #12) to ease verification.

Comment 14 Sandro Bonazzola 2015-12-23 13:42:44 UTC
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA

Comment 15 SATHEESARAN 2016-02-26 02:51:16 UTC
Tested with RHEV 3.6.3.3 with RHGS 3.1.2 RC. After adding UI plugin, tabs are listed only once


Note You need to log in before you can comment on or make changes to this bug.