Bug 1258464 - Improve error message about missing frontend for merge
Improve error message about missing frontend for merge
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmconf (Show other bugs)
22
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 08:58 EDT by markusN
Modified: 2015-12-07 15:28 EST (History)
3 users (show)

See Also:
Fixed In Version: rpmconf-1.0.14 rpmconf-1.0.16-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 15:28:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markusN 2015-08-31 08:58:06 EDT
When using fedup to update the local Fedora installation, the rpmconf tool suggested in the related Wiki page https://fedoraproject.org/wiki/FedUp#Cleaning_Up_Post_Upgrade is unclear how to define the needed merge tool.

(enhancement request migrated here from bug #990444)

[root@desktop ~]# rpmconf -a
Configuration file '/etc/systemd/journald.conf'
-rw-r--r--. 1 root root 969  4. Aug 08:23 /etc/systemd/journald.conf.rpmnew
-rw-r--r--. 1 root root 808 29. Aug 11:41 /etc/systemd/journald.conf

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      M     : merge configuration files
      Z     : background this process to examine the situation
      S     : skip this file
 The default action is to keep your current version.
*** aliases (Y/I/N/O/D/M/Z/S) [default=N] ? 
Your choice: D
Configuration file '/etc/systemd/journald.conf'
-rw-r--r--. 1 root root 969  4. Aug 08:23 /etc/systemd/journald.conf.rpmnew
-rw-r--r--. 1 root root 808 29. Aug 11:41 /etc/systemd/journald.conf

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      M     : merge configuration files
      Z     : background this process to examine the situation
      S     : skip this file
 The default action is to keep your current version.
*** aliases (Y/I/N/O/D/M/Z/S) [default=N] ? 
Your choice: M
ERROR:rpmconf:You did not selected any frontend for merge


Enhancement request:

Please provide a better error message. Instead of

ERROR:rpmconf:You did not selected any frontend for merge

may it be

ERROR:rpmconf:You did not selected any frontend for merge (define it with environment variable 'MERGE' or flag -f)


I am aware of "man rpmconf" - still a slightly more detailed error message would be just perfect. Thanks!
Comment 1 mathew 2015-09-25 10:05:26 EDT
Also, the error and the manual page should suggest frontends that actually exist in the repositories.

man rpmconf:

       -ftype, --frontend=type
              Define  which frontend should be used for merging. Valid options
              are: vimdiff, gvimdiff, diffuse, kdiff3, meld.

# rpmconf -a --frontend=vimdiff
Error: vimdiff is not installed
# yum search vimdiff
Warning: No matches found for: vimdiff
No matches found
Comment 2 Miroslav Suchý 2015-09-25 10:19:47 EDT
Since rpmconf-1.0.9 those dependencies are listed as soft deps:

# rpm -q --suggests rpmconf 
diffuse
kdiff3
meld
vim-X11
vim-enhanced

Dnf search does not work unless that word is listed in summary or description, you have to use full path:
# dnf whatprovides /usr/bin/vimdiff
Last metadata expiration check performed 0:35:43 ago on Fri Sep 25 15:40:53 2015.
vim-enhanced-2:7.4.827-1.fc22.x86_64 : A version of the VIM editor which includes recent enhancements
Repo        : @System

vim-enhanced-2:7.4.640-4.fc22.x86_64 : A version of the VIM editor which includes recent enhancements
Repo        : fedora

vim-enhanced-2:7.4.827-1.fc22.x86_64 : A version of the VIM editor which includes recent enhancements
Repo        : updates
Comment 3 Miroslav Suchý 2015-11-22 08:47:04 EST
Fixed in commit 
* 22c598b (HEAD -> master) 1258464 - improve error message
Comment 4 Fedora Update System 2015-11-30 05:03:32 EST
rpmconf-1.0.15-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 5 Fedora Update System 2015-11-30 21:22:48 EST
rpmconf-1.0.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmconf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 6 Fedora Update System 2015-12-01 07:24:03 EST
rpmconf-1.0.16-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 7 Fedora Update System 2015-12-01 17:31:20 EST
rpmconf-1.0.16-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmconf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 8 Fedora Update System 2015-12-07 15:28:24 EST
rpmconf-1.0.16-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.