This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 125847 - Gaim menu entry should be changed
Gaim menu entry should be changed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-06-12 06:48 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 17:04:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-06-12 06:48:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
The gaim menu entry is not GNOME HIG compliant. 
Please change it to contain the program name:

Gaim Messaging Client


Version-Release number of selected component (if applicable):
gaim-0.78-7

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:
Comment 1 Luke Schierer 2004-06-12 13:29:30 EDT
you do realize that we aren't a part of the gnome project right? 
Comment 2 Ivan Gyurdiev 2004-06-12 14:01:27 EDT
Actually I thought you were...
but in any case I don't see how this is relevant.

I was told (on fedora-devel) that any menu entries that are not 
GNOME HIG compliant should be changed.  I totally agree with this,
because otherwise the Fedora menus end up being the mess that they
currently are. 

The GNOME HIG seems like the proper guideline for what menu entries
should look like. Currently your says Messaging Client. This is not
acceptable, because I can have other messaging clients installed.
Furthermore it does not present the project name (gaim), which I think
is undesirable.
Comment 3 Havoc Pennington 2004-06-12 15:39:56 EDT
I think the generic name is suggested for "parts of the desktop" but
I'd say "messaging client" is kind of geeky (sort of like "X config
tool" vs. "Display") - how about "Chat" or "Instant Messaging" or
something?
Comment 4 Mark Doliner 2004-06-12 15:44:28 EDT
I changed Gaim CVS to use "Gaim Instant Messenger."  I'm not sure
where Red Hat stands on the issue, but I personally prefer this over
the alternatives of
-Gaim (previously in upstream CVS)
-Instant Messenger (used by the Fedora RPM)
-Gaim Messaging Client (suggested above)
Comment 5 Ethan Blanton 2004-06-12 16:30:25 EDT
I concur with Mark.
Comment 6 Luke Schierer 2004-06-12 16:45:14 EDT
yeah, if we aren't going to just say "Gaim" then "Gaim Instant
Messanger" is the best alternative. 
Comment 7 Ivan Gyurdiev 2004-06-12 17:08:40 EDT
I like it.
Comment 8 Havoc Pennington 2004-06-12 18:05:27 EDT
CLOSED->WORKSFORME means the developer could not reproduce the bug.

The bug should be open until the change lands in rawhide.
Comment 9 Warren Togami 2004-06-12 19:50:08 EDT
Havoc, is the desktop team okay with "Gaim Instant Messenger"?
Comment 10 Havoc Pennington 2004-06-12 23:16:42 EDT
Need Seth or Bryan to sign off.
Comment 11 Ivan Gyurdiev 2004-06-13 16:01:21 EDT
Relevant:

Gnome Icons, Gnome/KDE Menus need improvement

on fedora-devel
Comment 12 Bryan W Clark 2004-06-15 15:16:51 EDT
I just updated the HIG to make this section clearer.  Note the
GenericName only has the applications functionality and the Name has
the proper name + application functionality.  The HIG is now clear on
this and we're waiting for the f.d.o desktop entry spec to catch up.

Looks good, I'd be happy with these two for the .desktop file:

Name=Gaim Instant Messenger
GenericName=Instant Messenger
Comment 13 Mark Doliner 2004-06-15 18:16:46 EDT
Sweet.  I added the GenericName line to Gaim's gaim.desktop file.  Yay
for one fewer Fedora Gaim RPM patch being required.

Now that this is fixed upstream, I suppose this bug can be closed?
Comment 14 Warren Togami 2004-06-15 19:33:23 EDT
Translations still need to be fixed?
Also Red Hat's gaim package needs to begin using upstream .desktop?
Comment 15 Bryan W Clark 2004-06-16 14:46:19 EDT
Hold on, Sorry!  I just asked around and Alan Cox and others agree
"Instant Messenger" (tm) seems to be a trademark of AOL, so I believe
we would be asked by AOL (again) to not use this name.

In light of this, lets go with "IM" instead, it seems to be the best
alternative and probably the most recognizable.

And in talking with Seth about this (though I'm not in 100% agreement
with this solution), Fedora would probably be better off keeping the
names generic despite the standard.

Here's the issue, and it's a GNOME issue as well:

  The generic names are easier for users to understand, which is why
we want them.  The project names (Gaim, Epiphany and Mozilla) really
mean nothing to most people.

  When a user installs a new application that has the same generic
name (i.e. install FireFox) we don't want the "Web Browser" menu item
changing to now become "Epiphany Web Browser" after you install
"FireFox Web Browser".  Instead you really want Epiphany to remain
"Web Browser" and only the new "FireFox Web Browser" to use the Proper
+ Generic format.  This is because Epiphany is the Desktop web broswer
and should only carry the branding of the Desktop, not it's own
project name. 

  To do this we really need a way to recognize the GNOME base install
items from the 'post install' items and use the generic naming
conventions on the post install applications, but not on the GNOME
default installed applications.

  For now however it's best to go with changing the .desktop files to
keep the menu items from changing too much and keeping the brand in tact.

I'm going to get some dicussion moving on this on usability@gnome.org
so we can get some community input as well.

So lets finally go with (i know this is against the spec)

Name=IM
GenericName=IM
Comment 16 Luke Schierer 2004-06-16 14:55:12 EDT
"aim" in relation to instant messaging is trademarked as well, gaim
already had that come up about 3 years ago. its interesting that at
least once a year i hear about aol's trade marks from someone in great
britan or from someone who has talked to someone in great britan. is
trademark law there so substantially different that not having to
change our name here wouldn't hold there? 

and yes, i know, this thread is specifically talking about "Instant
Messanger" not "aim" but the same should hold true of each. 
Comment 17 Ivan Gyurdiev 2004-06-16 15:24:23 EDT
"Hold on, Sorry!  I just asked around and Alan Cox and others agree
"Instant Messenger" (tm) seems to be a trademark of AOL, so I believe
we would be asked by AOL (again) to not use this name."

In which case the Kopete Tooltip needs to be changed as well.

"The generic names are easier for users to understand, which is why
we want them.  The project names (Gaim, Epiphany and Mozilla) really
mean nothing to most people."

Well, I'm not sure that's true. I appreciate being able to tell what
application I'm about to launch. You're favoring the new and
unexperienced user here, and I don't like that. Futhermore getting new
users familiar with the project name means they might be able to
recognize the application in other contexts, for example..launch it
from the command line.

"When a user installs a new application that has the same generic
name (i.e. install FireFox) we don't want the "Web Browser" menu item
changing to now become "Epiphany Web Browser" after you install
"FireFox Web Browser".  Instead you really want Epiphany to remain
"Web Browser" and only the new "FireFox Web Browser" to use the Proper
+ Generic format.  This is because Epiphany is the Desktop web broswer
and should only carry the branding of the Desktop, not it's own
project name."

I don't use Epiphany, and I don't like the idea of designating it as
THE WEB BROWSER, firefox being a second-class citizen here. I'd rather
have consistency in the naming scheme than anything more complicated.
  
"To do this we really need a way to recognize the GNOME base install
items from the 'post install' items and use the generic naming
conventions on the post install applications, but not on the GNOME
default installed applications."

I don't care what the GNOME base install items are. I am completely
uninterested as to which apps are part of gnome and which ones are
not. Therefore any efforts to identify one from the other are
misguided IMHO.

"Name=IM
GenericName=IM"

That's a 2 letter abbreviation... it's not a name of any kind.
Makes no sense to me. I see your AOL point, but I disagree with the
rest. The fact that it's agains the spec is not a good thing either.
How about:

Name = Gaim Messenger
GenericName = ...whatever...



Comment 18 Havoc Pennington 2004-06-16 19:07:28 EDT
Can we keep the meta-discussion on the fedora-desktop-list thread
rather than the specific bug about Gaim? i.e. let's come back to this
bug when we know what the overall guidelines are.

Bryan: from the list thread, I thought we wanted something like this
upstream:
 Name=Gaim Chat
 GenericName=Chat
Which we'd then munge in our spec file to:
 Name=Chat
 GenericName=Chat
(just saying "Chat", maybe it's "IM")

Anyhow, let's go back to the mailing list for the general point, and
just come back here for IM-specific aspects.
Comment 19 Mark Doliner 2004-06-18 00:51:06 EDT
It's too bad Instant Messenger is trademarked, it's such a good
description :-)
List of Possibilities:
Gaim Internet Messenger (my personal favorite)
Gaim IM (my second choice)
Gaim Internet Chat
Gaim Chat and Messaging
Gaim Messaging and Chat
Comment 20 Bryan W Clark 2004-07-07 02:52:05 EDT
What we'd like to see in the upstream is:
  Name=Gaim IM
  GenericName=IM

However what we're going to want for Fedora is:
  Name=IM
  GenericName=IM

IM is short and understood, even AOL uses it however they don't seem
to have the trademark on it.  Internet Messenger is close, but Instant
Messenger is the recognized name and with the slight difference we'll
just be confusing.

Since the Name/GenericName handling code isn't quite doing what we
want we'll have to wait until is does the names right before we can
use the upstream version.

I explained this GenericName thing a little bit more in bug 125848
Comment 21 Daniel Reed 2004-08-13 17:04:00 EDT
All localized Name and GenericName entries have been replaced with one
generic Name=IM and GenericName=IM.

Note You need to log in before you can comment on or make changes to this bug.