Bug 1258510 - [RFE] Add LANG installer Check
[RFE] Add LANG installer Check
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity medium (vote)
: Beta
: --
Assigned To: Bryan Kearney
jcallaha
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks: 1245506
  Show dependency treegraph
 
Reported: 2015-08-31 10:15 EDT by Bryan Kearney
Modified: 2016-07-27 04:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:55:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12881 None None None 2016-04-22 12:57 EDT

  None (edit)
Description Bryan Kearney 2015-08-31 10:15:01 EDT
There should be an instaleller check to ensure that the LANG environemnt is not set to C. This is case 1 from 1245506.
Comment 2 Bryan Kearney 2015-12-18 15:21:43 EST
Created redmine issue http://projects.theforeman.org/issues/12881 from this bug
Comment 3 Bryan Kearney 2015-12-18 16:01:05 EST
Upstream bug assigned to bkearney@redhat.com
Comment 4 Bryan Kearney 2016-01-07 18:01:16 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/12881 has been closed
-------------
Anonymous
Applied in changeset commit:katello-installer|e30bc930836d26367d5aafbb0eac429d907df8d6.
Comment 8 jcallaha 2016-05-05 09:29:31 EDT
Verified in Satellite 6.2 Beta RC. The installer now makes the appropriate check.

[root@mgmt5 ~]# foreman-installer
The LANG envrionment variable should not be set to C
Your system does not meet configuration criteria
Comment 10 errata-xmlrpc 2016-07-27 04:55:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.