Bug 125852 - Ethereal menu entry should be changed
Ethereal menu entry should be changed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ethereal (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-06-12 07:00 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 04:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-06-12 07:00:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
The Ethereal menu entry is not GNOME HIG compliant. 
Please change it to say: 

Ethereal Traffic Analyzer



Version-Release number of selected component (if applicable):
ethereal-0.10.4-1

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:
Comment 1 Ivan Gyurdiev 2004-06-13 16:04:54 EDT
Relevant:

Gnome Icons, Gnome/KDE Menus need improvement

on fedora-devel
Comment 2 Phil Knirsch 2004-06-15 10:58:44 EDT
Why is Network Traffic Analyer not HIG compliant? %^)

Read ya, Phil
Comment 3 Ivan Gyurdiev 2004-06-15 11:40:45 EDT
The menu entry says Ethereal, which is not acceptable, because it
doesn't explain what the program does. The suggested "Network Traffic
Analyzer" is also not a good idea because it doesn't include the
project name (Ethereal), and if there's ever a competing program that
does the same thing it will conflict. 

The GNOME HIG says menu entries should follow the pattern:
app_name app_function. However, the kaffeine maintaner has pointed out
that this can be constructed from parts of the .desktop file, which is
currently being discussed (or I hope it is) on the fedora-devel thread
listed above.

So I wouldn't make any changes yet, but if you'd like to discuss this,
followup to the thread above.
Comment 4 Ivan Gyurdiev 2004-07-22 20:28:15 EDT
The decision was that the .desktop file will be formatted as follows:

Name = <appname> <function>
GenericName = <function>

The the GNOME and KDE menus can work with that.
In particular the GNOME menu will be modified to not display the
appname for apps that are not core GNOME apps only. 

Hence, I recommend 
Name = Ethereal Network Analyzer
GenericName = Network Analyzer

or something like that.

The reason GenericName can't be appended to Name to construct the full
name is that translations won't work properly. 
Comment 5 Ivan Gyurdiev 2004-07-22 20:33:25 EDT
However, since the code in question has not been written yet Bryan
Clarke has recommended on several bugs that things stay as they are -
(using GenericName as Name) until written. Then things will change
like I described. 

Note You need to log in before you can comment on or make changes to this bug.