Bug 1258539 - docker checkpoint/restore with criu fails sometimes
docker checkpoint/restore with criu fails sometimes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: criu (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Reber
Chao Ye
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 11:04 EDT by Adrian Reber
Modified: 2015-11-24 01:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 09:50:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Reber 2015-08-31 11:04:41 EDT
The experimental docker feature checkpoint/restore relies on criu. The current criu version 1.6.1 unfortunately sometimes fails to restore a docker process.

A fix already exists and just needs to be applied to criu 1.6.1.
Comment 4 errata-xmlrpc 2015-11-19 09:50:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2458.html

Note You need to log in before you can comment on or make changes to this bug.