Bug 125855 - Emacs menu entry should be removed
Emacs menu entry should be removed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-06-12 07:10 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-03 15:35:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-06-12 07:10:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
The emacs menu entry is not GNOME HIG compliant.
Please change it to say:

Emacs Text Editor

Version-Release number of selected component (if applicable):
emacs-21.3-12

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:
Comment 1 Ivan Gyurdiev 2004-06-13 16:04:22 EDT
Relevant:

Gnome Icons, Gnome/KDE Menus need improvement

on fedora-devel
Comment 2 Seth Nickell 2004-06-16 12:22:16 EDT
Opening emacs from the menu seems silly. If you know how to use emacs,
you're almost always using a terminal to launch it. Given that the
value of the menu entry seems fairly low, I'd like to remove "booby
traps" from the menus that launch archane old unix programs.
Comment 3 Ivan Gyurdiev 2004-06-16 13:33:14 EDT
It's your decision - I don't use emacs personally.
If the menu is kept, however, it would need to be changed.

Comment 4 Bryan W Clark 2004-07-07 02:42:56 EDT
Since this is not our default Text Editor, this bug is correct that
the menu entry needs to be changed.

I disagree with the person in comment 2, emacs is a graphical program
with buttons for save and open.  Since this is located under the
Programming menu entry I see it as less of a booby trap and more of a
curiosity trap that isn't harmful.

That said, I'm not willing to fight for it remaining though.  If
you're passionate about it going, then send it away.
Comment 5 Jens Petersen 2004-07-13 03:27:40 EDT
FWIW I updated the desktop files for Emacs and XEmacs to fix
this in my tree.  I have seen Emacs users with an Emacs icon
in their gnome panel say, so the fix is needed there anyway.
Whether it should appear in the main menu is indeed debatable.
Comment 6 Bryan W Clark 2004-09-03 15:35:20 EDT
I'm going to close this as a WONTFIX, emacs can remain in the menu
under the programming submenu.  Thanks for updating the .desktop files.

Note You need to log in before you can comment on or make changes to this bug.