Bug 1258560 - /usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.html: /bin/sh: horizon.utils.scss_filter.HorizonScssFilter: command not found
/usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.htm...
Status: CLOSED RAWHIDE
Product: RDO
Classification: Community
Component: distribution (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity high
: ---
: Kilo
Assigned To: Alan Pevec
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 11:59 EDT by wes hayutin
Modified: 2016-04-18 02:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 11:05:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
controller logs (9.44 MB, application/x-gzip)
2015-08-31 11:59 EDT, wes hayutin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 219474 None None None Never

  None (edit)
Description wes hayutin 2015-08-31 11:59:26 EDT
Created attachment 1068690 [details]
controller logs

Description of problem:

Full logs can be found:
https://prod-rdojenkins.rhcloud.com/view/RDO-Liberty-Delorean-Trunk/job/khaleesi-rdo-liberty-delorean-centos-7.0-aio-packstack-neutron-ml2-vxlan-rabbitmq-permissive-tempest-rpm-minimal/70/artifact/khaleesi/collected_files/rdo-pksk-pfe2b-rhos-ci-70-controller.tar.bz2



172.16.0.123_nova.pp:                                [ DONE ]
10:46:35 
172.16.0.123_horizon.pp:                          [ ERROR ]
10:46:35 Applying Puppet manifests                         [ ERROR ]
10:46:35 
10:46:35 ERROR : Error appeared during Puppet run: 172.16.0.123_horizon.pp
10:46:35 Notice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: CommandError: An error occured during rendering /usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.html: /bin/sh: horizon.utils.scss_filter.HorizonScssFilter: command not found
10:46:35 You will find full trace in log /var/tmp/packstack/20150831-141955-qb_TLI/manifests/172.16.0.123_horizon.pp.log
10:46:35 Please check log file /var/tmp/packstack/20150831-141955-qb_TLI/openstack-setup.log for more information




[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: [0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: 964 static files copied to '/usr/share/openstack-dashboard/static'.[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: WARNING:root:"dashboards" and "default_dashboard" in (local_)settings is DEPRECATED now and may be unsupported in some future release. The preferred way to specify the order of dashboards and the default dashboard is the pluggable dashboard mechanism (in /usr/share/openstack-dashboard/openstack_dashboard/enabled, /usr/share/openstack-dashboard/openstack_dashboard/local/enabled).[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: WARNING:py.warnings:RemovedInDjango19Warning: "requires_model_validation" is deprecated in favor of "requires_system_checks".[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: WARNING:py.warnings:RemovedInDjango19Warning: SortedDict is deprecated and will be removed in Django 1.9.[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: WARNING:py.warnings:RemovedInDjango19Warning: Loading the `url` tag from the `future` library is deprecated and will be removed in Django 1.9. Use the default `url` tag instead.[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: WARNING:py.warnings:RemovedInDjango19Warning: SortedDict is deprecated and will be removed in Django 1.9.[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: CommandError: An error occured during rendering /usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.html: /bin/sh: horizon.utils.scss_filter.HorizonScssFilter: command not found[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: Found 'compress' tags in:[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: 	/usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.html[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: 	/usr/share/openstack-dashboard/openstack_dashboard/templates/horizon/_conf.html[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: 	/usr/share/openstack-dashboard/openstack_dashboard/templates/horizon/_scripts.html[0m
[mNotice: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]/returns: Compressing... [0m
[1;31mError: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]: Failed to call refresh: /usr/share/openstack-dashboard/manage.py collectstatic --noinput --clear && /usr/share/openstack-dashboard/manage.py compress --force returned 1 instead of one of [0][0m
[1;31mError: /Stage[main]/Horizon/Exec[refresh_horizon_django_cache]: /usr/share/openstack-dashboard/manage.py collectstatic --noinput --clear && /usr/share/openstack-dashboard/manage.py compress --force returned 1 instead of one of [0][0m
Comment 1 Matthias Runge 2015-09-01 03:27:34 EDT
Horizon in liberty requires:
python-django-scss >= 2.0.2
python-scss >=1.3.4

(all in f23 repository)
Comment 2 Alan Pevec 2015-09-01 17:46:27 EDT
We have scss built for RDO in Cloud SIG common target, shared by all release.

stable/kilo has django-pyscss>=1.0.3,<2.0.0 - is the upper cap really true or just preemptive i.e. would Kilo work with python-django-scss 2.0.2 ?
Comment 3 Alan Pevec 2015-09-01 18:05:06 EDT
> i.e. would Kilo work with python-django-scss 2.0.2 ?

correction: python-django-pyscss 2.0.2
Comment 4 Alan Pevec 2015-09-01 18:21:33 EDT
> stable/kilo has django-pyscss>=1.0.3,<2.0.0 - is the upper cap really true
> or just preemptive

Looks like a quickfix cap, done just before Kilo release:

https://review.openstack.org/176726

caused by older preemptive cap:

https://review.openstack.org/122410


pyScss cap was raised on master/Liberty and afaict it should actually be backported to stable/kilo b/c pyScss < 1.3 is buggy?

https://review.openstack.org/179260
Comment 5 Alan Pevec 2015-09-01 18:23:33 EDT
Upper constraints on stable/kilo has django-pyscss===2.0.2

https://git.openstack.org/cgit/openstack/requirements/tree/upper-constraints.txt?h=stable/kilo#n95
Comment 6 Matthias Runge 2015-09-02 02:42:50 EDT
It took me a bit to find the commit fixing scss to make it compatible with python-scss==1.3.4 (aka pyScss) and python-django-scss. It isn't backported to kilo (yet)

Backport review is this: https://review.openstack.org/219574
Comment 7 wes hayutin 2015-09-09 08:17:29 EDT
Looks like https://review.openstack.org/219574 merged
Comment 8 Matthias Runge 2015-09-09 08:19:35 EDT
2015.1.1 packages based on fedora packages are fine with later python-scss and python-django-scss
Comment 9 Alan Pevec 2015-09-09 20:53:42 EDT
(In reply to Matthias Runge from comment #8)
> 2015.1.1 packages based on fedora packages are fine with later python-scss
> and python-django-scss

Please send rdo-update request for pyScss update in RDO-Kilo then.

For now, I've prepared new deps repos for Delorean Trunk, to be used instead of RDO Kilo + EPEL7.
Comment 10 Matthias Runge 2015-09-10 02:13:08 EDT
(In reply to Alan Pevec from comment #9)
> (In reply to Matthias Runge from comment #8)
> > 2015.1.1 packages based on fedora packages are fine with later python-scss
> > and python-django-scss
> 
> Please send rdo-update request for pyScss update in RDO-Kilo then.
> 
> For now, I've prepared new deps repos for Delorean Trunk, to be used instead
> of RDO Kilo + EPEL7.

I can't build them in centos, and it will break older installations based on epel7.
Comment 11 Alan Pevec 2015-09-15 03:09:36 EDT
We now have Delorean Trunk deps repos provided at
http://trunk.rdoproject.org/centos7/delorean-deps.repo
which contain updated dependencies.

This is now used by Delorean Trunk builds: https://review.gerrithub.io/246426
and David has opened khaleesi* reviews to switch trunk CI jobs to use them: 
https://review.gerrithub.io/246557 https://review.gerrithub.io/246556
Comment 12 David Moreau Simard 2015-09-16 10:34:14 EDT
Can we close this bug ? It's fixed and provided by new packages in trunk.
Comment 13 Alan Pevec 2015-09-16 11:06:05 EDT
RDO RAWHIDE = Delorean Trunk :)

Note You need to log in before you can comment on or make changes to this bug.