Bug 1258576 - RDO liberty packstack --allinone fails on demo provision of glance
RDO liberty packstack --allinone fails on demo provision of glance
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-puppet-modules (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity high
: Milestone3
: trunk
Assigned To: Javier Peña
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 12:44 EDT by wes hayutin
Modified: 2016-04-18 02:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1-dev.31e650ef630ae68a34bb3743121479b7389aa9cb_c6e4999d.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:07:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 244964 None None None Never

  None (edit)
Description wes hayutin 2015-08-31 12:44:24 EDT
Description of problem:

Recreate:
https://repos.fedorapeople.org/repos/openstack/openstack-trunk/2015-08-20/00README.html

172.16.7.19_provision_glance:                     [ ERROR ]              
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 172.16.7.19_provision_glance
Error: Execution of '/usr/bin/glance --os-tenant-name services --os-username glance --os-password dd3877f8a96746f0 --os-region-name RegionOne --os-auth-url http://172.16.7.19:35357/ image-create --name=cirros --is-public=True --container-format=bare --disk-format=qcow2 --copy-from=http://download.cirros-cloud.net/0.3.3/cirros-0.3.3-x86_64-disk.img' returned 2: usage: glance [--version] [-d] [-v] [--get-schema] [--timeout TIMEOUT]
You will find full trace in log /var/tmp/packstack/20150831-161805-mTtQf2/manifests/172.16.7.19_provision_glance.log



ESC[mNotice: Compiled catalog for centos7-packstack4-permanent.novalocal in environment production in 0.18 secondsESC[0m
ESC[1;31mError: Execution of '/usr/bin/glance --os-tenant-name services --os-username glance --os-password dd3877f8a96746f0 --os-region-name RegionOne --os-auth-url http://172.16.7.19:35357/ image-create --name=cirros --is-public=True --container-format=bare --disk-format=qcow2 --copy-from=http://download.cirros-cloud.net/0.3.3/cirros-0.3.3-x86_64-disk.img' returned 2: usage: glance [--version] [-d] [-v] [--get-schema] [--timeout TIMEOUT]
              [--no-ssl-compression] [-f] [--os-image-url OS_IMAGE_URL]
              [--os-image-api-version OS_IMAGE_API_VERSION]
              [--profile HMAC_KEY] [-k] [--os-cert OS_CERT]
              [--cert-file OS_CERT] [--os-key OS_KEY] [--key-file OS_KEY]
              [--os-cacert <ca-certificate-file>] [--ca-file OS_CACERT]
              [--os-username OS_USERNAME] [--os-user-id OS_USER_ID]
              [--os-user-domain-id OS_USER_DOMAIN_ID]
              [--os-user-domain-name OS_USER_DOMAIN_NAME]
              [--os-project-id OS_PROJECT_ID]
              [--os-project-name OS_PROJECT_NAME]
              [--os-project-domain-id OS_PROJECT_DOMAIN_ID]
              [--os-project-domain-name OS_PROJECT_DOMAIN_NAME]
              [--os-password OS_PASSWORD] [--os-tenant-id OS_TENANT_ID]
              [--os-tenant-name OS_TENANT_NAME] [--os-auth-url OS_AUTH_URL]
              [--os-region-name OS_REGION_NAME]
              [--os-auth-token OS_AUTH_TOKEN]
              [--os-service-type OS_SERVICE_TYPE]
              [--os-endpoint-type OS_ENDPOINT_TYPE]
              <subcommand> ...


Repo-id      : base/7/x86_64
Repo-name    : CentOS-7 - Base
Repo-revision: 1427842153
Repo-updated : Tue Mar 31 22:50:46 2015
Repo-pkgs    : 8,652
Repo-size    : 6.3 G
Repo-mirrors : http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=genclo
Repo-baseurl : http://mirrors.advancedhosters.com/centos/7.1.1503/os/x86_64/ (9 more)
Repo-expire  : 21,600 second(s) (last: Mon Aug 31 16:18:11 2015)
Repo-filename: /etc/yum.repos.d/CentOS-Base.repo

Repo-id      : delorean
Repo-name    : delorean-2015-08-20
Repo-revision: 1440147070
Repo-updated : Fri Aug 21 08:51:12 2015
Repo-pkgs    : 225
Repo-size    : 53 M
Repo-baseurl : https://rdoproject.org/repos/openstack-trunk/2015-08-20/
Repo-expire  : 21,600 second(s) (last: Mon Aug 31 16:18:11 2015)
Repo-excluded: 97
Repo-filename: /etc/yum.repos.d/delorean.repo

Repo-id      : epel/x86_64
Repo-name    : Extra Packages for Enterprise Linux 7 - x86_64
Repo-revision: 1440951909
Repo-tags    : binary-x86_64
Repo-updated : Sun Aug 30 17:06:37 2015
Repo-pkgs    : 8,471
Repo-size    : 6.6 G
Repo-metalink: https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=x86_64
  Updated    : Fri Aug 28 03:02:35 2015
Repo-baseurl : http://mirror.cogentco.com/pub/linux/epel/7/x86_64/ (34 more)
Repo-expire  : 21,600 second(s) (last: Mon Aug 31 16:18:12 2015)
Repo-excluded: 7
Repo-filename: /etc/yum.repos.d/epel.repo

Repo-id      : extras/7/x86_64
Repo-name    : CentOS-7 - Extras
Repo-revision: 1439484001
Repo-updated : Thu Aug 13 16:40:15 2015
Repo-pkgs    : 180
Repo-size    : 742 M
Repo-mirrors : http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=extras&infra=genclo
Repo-baseurl : http://mirror.es.its.nyu.edu/centos/7.1.1503/extras/x86_64/ (9 more)
Repo-expire  : 21,600 second(s) (last: Mon Aug 31 16:18:12 2015)
Repo-filename: /etc/yum.repos.d/CentOS-Base.repo

Repo-id      : openstack-kilo
Repo-name    : OpenStack Kilo Repository
Repo-revision: 1440426054
Repo-updated : Mon Aug 24 14:21:00 2015
Repo-pkgs    : 556
Repo-size    : 420 M
Repo-baseurl : http://repos.fedorapeople.org/repos/openstack/openstack-kilo/el7/
Repo-expire  : 21,600 second(s) (last: Mon Aug 31 16:18:12 2015)
Repo-excluded: 351
Repo-filename: /etc/yum.repos.d/rdo-release.repo

Repo-id      : updates/7/x86_64
Repo-name    : CentOS-7 - Updates
Repo-revision: 1440708516
Repo-updated : Thu Aug 27 20:49:51 2015
Repo-pkgs    : 1,248
Repo-size    : 3.7 G
Repo-mirrors : http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=updates&infra=genclo
Repo-baseurl : http://mirror.linux.duke.edu/pub/centos/7.1.1503/updates/x86_64/ (9 more)
Repo-expire  : 21,600 second(s) (last: Mon Aug 31 16:18:13 2015)
Repo-filename: /etc/yum.repos.d/CentOS-Base.repo

repolist: 19,332
Comment 1 Alan Pevec 2015-08-31 17:34:38 EDT
Analysis by afazekas:

>> The glance client help shows the v1, but the client in this case
>> behaves as v2 client.
>>
>> The v2 help `/usr/bin/glance --os-image-api-version 2 help image
>> -create` does not indicates
>> these arguments.
>>
>> The glance client can be asked to work as v1 client by adding the `-
>> -os-image-api-version 1` arg to client,
>> (likely puppet module change required).
>>
>> Also upstream does not uses or testing the glance client in dvsm
>> setups anymore,
>> it is switched to the `openstack` client since long.
Comment 2 Alan Pevec 2015-08-31 17:41:28 EDT
This broke since Merge "Use API v2 as default" in glanceclient:

http://git.openstack.org/cgit/openstack/python-glanceclient/commit/?id=13af69039671d842167cb66e25b0dfbd1ce89724
Comment 3 Javier Peña 2015-09-01 07:30:21 EDT
This was fixed upstream in puppet-glance. The fix was included in openstack-puppet-modules with https://review.gerrithub.io/244964
Comment 4 Alan Pevec 2015-09-01 17:31:57 EDT
Delorean Trunk builds o-p-m from master-patches branch, has it been rebased on top of https://review.gerrithub.io/244964 ?
Comment 5 Alan Pevec 2015-09-01 17:39:21 EDT
(In reply to Javier Peña from comment #3)
> This was fixed upstream in puppet-glance. The fix was included in
> openstack-puppet-modules with https://review.gerrithub.io/244964

This OPM update included puppet-glance changes 92180ae9a13c9c48f4f1bec7a0805e02b768fb51..4e8e53bff3818c7cfda3317426281d8f6c4ea295

Specific upstream fix is https://review.openstack.org/172580

Note You need to log in before you can comment on or make changes to this bug.