Bug 1258579 - vnc console to instance is not working
vnc console to instance is not working
Status: CLOSED DUPLICATE of bug 1257753
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 12:52 EDT by bigswitch
Modified: 2015-09-15 19:26 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 19:26:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bigswitch 2015-08-31 12:52:36 EDT
Description of problem:
Deploy instance, and attempt to access its console fail. chrome browser display message "The server closed the connection without sending any data."

Version-Release number of selected component (if applicable):
RHEL 7.0

How reproducible:
100%

Steps to Reproduce:
1. Launch an instance from Horizon, using cirros image.
2. Click on instance name, and click on console
3. console window show up with a grey screen and message "The server closed the connection without sending any data."
4. Clicking on "Click here to show only console" launches a new window with the error "Unable to load the webpage because the server sent no data."

Actual results:


Expected results:
should be able to access VM console

Additional info:
Comment 3 bigswitch 2015-08-31 13:07:59 EDT
I notice port 5900 is not opened in iptables on the compute-nodes. should it be opened to accept vnc request?
Comment 4 Sahid Ferdjaoui 2015-09-01 07:17:17 EDT
We need more information of environment to correctly handle your problem but about your question it seems not necessary to open port 5900.

  Please refer yourself to:

    http://docs.openstack.org/kilo/config-reference/content/list-of-compute-config-options.html (vnc section)

  and https://access.redhat.com/documentation/en/red-hat-enterprise-linux-openstack-platform/version-7/red-hat-enterprise-linux-openstack-platform-7-installation-reference/chapter-8-install-the-compute-service
Comment 5 bigswitch 2015-09-15 19:26:22 EDT

*** This bug has been marked as a duplicate of bug 1257753 ***

Note You need to log in before you can comment on or make changes to this bug.