Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1258626

Summary: realmdomains-mod --add-domain command throwing error when doamin already is in forwardzone.
Product: Red Hat Enterprise Linux 7 Reporter: Varun Mylaraiah <mvarun>
Component: ipaAssignee: IPA Maintainers <ipa-maint>
Status: CLOSED ERRATA QA Contact: Namita Soman <nsoman>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.2CC: ksiddiqu, mbasti, mkosek, pvoborni, rcritten
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-04 05:46:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Varun Mylaraiah 2015-08-31 20:15:38 UTC
Description of problem:
realmdomains-mod --add-domain command throwing error when doamin already is in forwardzone

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-8.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.On IPA server, add conditional forwarder for domain.
2.try to add a domain to the list of IPA realmdomains (domain should already setup as forwardzone)

Actual results:
ipa: ERROR: no modifications to be performed
and 
ipa: ERROR: invalid 'dnszoneidnsname': only master zones can contain records (after remove it and re-add it)


Additional info:
root@master72 ~]# ipa realmdomains-mod --add-domain=adlabs.com
ipa: ERROR: no modifications to be performed

[root@master72 ~]# ipa realmdomains-show
Domain: adlabs.com, ipa.adlabs.com

[root@master72 ~]# ipa realmdomains-mod --del-domain=adlabs.com
ipa: ERROR: invalid 'dnszoneidnsname': only master zones can contain records
 
[root@master72 ~]# ipa realmdomains-show
  Domain: ipa.adlabs.com
 
[root@master72 ~]# ipa realmdomains-mod --add-domain=adlabs.com
ipa: ERROR: invalid 'dnszoneidnsname': only master zones can contain records
 
[root@master72 ~]# ipa realmdomains-show
  Domain: adlabs.com, ipa.adlabs.com

Comment 2 Petr Vobornik 2015-09-01 08:16:11 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5278

Comment 6 Mike McCune 2016-03-28 22:43:24 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune with any questions

Comment 8 Varun Mylaraiah 2016-09-19 06:49:21 UTC
Verified
ipa-server-4.4.0-12.el7.x86_64

[root@master73 ~]# ipa realmdomains-show
  Domain: ytestrelm.test

[root@master73 ~]# ipa dnszone-add newzone.test
  Zone name: newzone.test.
  Active zone: TRUE
  Authoritative nameserver: master73.ytestrelm.test.
  Administrator e-mail address: hostmaster
  SOA serial: 1474267032
  SOA refresh: 3600
  SOA retry: 900
  SOA expire: 1209600
  SOA minimum: 3600
  BIND update policy: grant YTESTRELM.TEST krb5-self * A; grant YTESTRELM.TEST krb5-self * AAAA; grant YTESTRELM.TEST krb5-self * SSHFP;
  Dynamic update: FALSE
  Allow query: any;
  Allow transfer: none;

[root@master73 ~]# ipa realmdomains-show
  Domain: ytestrelm.test, newzone.test

[root@master73 ~]# ipa realmdomains-mod --del-domain=newzone.test
  Domain: ytestrelm.test

[root@master73 ~]# ipa realmdomains-mod --add-domain=newzone.test
ipa: ERROR: invalid 'domain': The realm of the following domains could not be detected: newzone.test. If these are domains that belong to the this realm, please create a _kerberos TXT record containing "YTESTRELM.TEST" in each of them.

[root@master73 ~]# ipa realmdomains-mod --add-domain=newzone.test --force
  Domain: ytestrelm.test, newzone.test

[root@master73 ~]# ipa realmdomains-mod --del-domain=newzone.test
  Domain: ytestrelm.test

Comment 10 errata-xmlrpc 2016-11-04 05:46:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html