Bug 1258626
| Summary: | realmdomains-mod --add-domain command throwing error when doamin already is in forwardzone. | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 7 | Reporter: | Varun Mylaraiah <mvarun> |
| Component: | ipa | Assignee: | IPA Maintainers <ipa-maint> |
| Status: | CLOSED ERRATA | QA Contact: | Namita Soman <nsoman> |
| Severity: | unspecified | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 7.2 | CC: | ksiddiqu, mbasti, mkosek, pvoborni, rcritten |
| Target Milestone: | rc | ||
| Target Release: | --- | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | ipa-4.4.0-0.el7.1.alpha1 | Doc Type: | Bug Fix |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2016-11-04 05:46:22 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Varun Mylaraiah
2015-08-31 20:15:38 UTC
Upstream ticket: https://fedorahosted.org/freeipa/ticket/5278 Fixed upstream master: https://fedorahosted.org/freeipa/changeset/4ceae037f5f756b0e690f8ec6e4729b42d2393b1 https://fedorahosted.org/freeipa/changeset/fc6e1f0bb5e09c1c7036a0cebdb54905f34b1fb9 https://fedorahosted.org/freeipa/changeset/6a2f47acbe301759899d477e524af8968a7c97c1 https://fedorahosted.org/freeipa/changeset/1e1d6d15c65357b1475917597ffa715ad9d6c8c1 https://fedorahosted.org/freeipa/changeset/dae9c6cbc164c8d1d5da22013193f2b1778e4d17 https://fedorahosted.org/freeipa/changeset/12840e0bfa545341c448276c4803a49cbae63e8a ipa-4-2: https://fedorahosted.org/freeipa/changeset/6248ae262e8d7ec46128aedd6200230505711cff https://fedorahosted.org/freeipa/changeset/a593abd6e8461132bdebff53304ac230b6d7d9af https://fedorahosted.org/freeipa/changeset/3bcd894de26383b37475ed8fc8d3cee36cd57645 https://fedorahosted.org/freeipa/changeset/01a75c6a8914fcda929cd23f883f2165708c874c https://fedorahosted.org/freeipa/changeset/31e7a7e19d5cd0930ba56b25a96e2998383d990e https://fedorahosted.org/freeipa/changeset/291aa25acd5df24b8bcc36fc02f6af0cc4f7d0f9 This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune with any questions Verified ipa-server-4.4.0-12.el7.x86_64 [root@master73 ~]# ipa realmdomains-show Domain: ytestrelm.test [root@master73 ~]# ipa dnszone-add newzone.test Zone name: newzone.test. Active zone: TRUE Authoritative nameserver: master73.ytestrelm.test. Administrator e-mail address: hostmaster SOA serial: 1474267032 SOA refresh: 3600 SOA retry: 900 SOA expire: 1209600 SOA minimum: 3600 BIND update policy: grant YTESTRELM.TEST krb5-self * A; grant YTESTRELM.TEST krb5-self * AAAA; grant YTESTRELM.TEST krb5-self * SSHFP; Dynamic update: FALSE Allow query: any; Allow transfer: none; [root@master73 ~]# ipa realmdomains-show Domain: ytestrelm.test, newzone.test [root@master73 ~]# ipa realmdomains-mod --del-domain=newzone.test Domain: ytestrelm.test [root@master73 ~]# ipa realmdomains-mod --add-domain=newzone.test ipa: ERROR: invalid 'domain': The realm of the following domains could not be detected: newzone.test. If these are domains that belong to the this realm, please create a _kerberos TXT record containing "YTESTRELM.TEST" in each of them. [root@master73 ~]# ipa realmdomains-mod --add-domain=newzone.test --force Domain: ytestrelm.test, newzone.test [root@master73 ~]# ipa realmdomains-mod --del-domain=newzone.test Domain: ytestrelm.test Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://rhn.redhat.com/errata/RHBA-2016-2404.html |