Bug 1258626 - realmdomains-mod --add-domain command throwing error when doamin already is in forwardzone.
realmdomains-mod --add-domain command throwing error when doamin already is i...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 16:15 EDT by Varun Mylaraiah
Modified: 2016-11-04 01:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:46:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Varun Mylaraiah 2015-08-31 16:15:38 EDT
Description of problem:
realmdomains-mod --add-domain command throwing error when doamin already is in forwardzone

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-8.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.On IPA server, add conditional forwarder for domain.
2.try to add a domain to the list of IPA realmdomains (domain should already setup as forwardzone)

Actual results:
ipa: ERROR: no modifications to be performed
and 
ipa: ERROR: invalid 'dnszoneidnsname': only master zones can contain records (after remove it and re-add it)


Additional info:
root@master72 ~]# ipa realmdomains-mod --add-domain=adlabs.com
ipa: ERROR: no modifications to be performed

[root@master72 ~]# ipa realmdomains-show
Domain: adlabs.com, ipa.adlabs.com

[root@master72 ~]# ipa realmdomains-mod --del-domain=adlabs.com
ipa: ERROR: invalid 'dnszoneidnsname': only master zones can contain records
 
[root@master72 ~]# ipa realmdomains-show
  Domain: ipa.adlabs.com
 
[root@master72 ~]# ipa realmdomains-mod --add-domain=adlabs.com
ipa: ERROR: invalid 'dnszoneidnsname': only master zones can contain records
 
[root@master72 ~]# ipa realmdomains-show
  Domain: adlabs.com, ipa.adlabs.com
Comment 2 Petr Vobornik 2015-09-01 04:16:11 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5278
Comment 6 Mike McCune 2016-03-28 18:43:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 Varun Mylaraiah 2016-09-19 02:49:21 EDT
Verified
ipa-server-4.4.0-12.el7.x86_64

[root@master73 ~]# ipa realmdomains-show
  Domain: ytestrelm.test

[root@master73 ~]# ipa dnszone-add newzone.test
  Zone name: newzone.test.
  Active zone: TRUE
  Authoritative nameserver: master73.ytestrelm.test.
  Administrator e-mail address: hostmaster
  SOA serial: 1474267032
  SOA refresh: 3600
  SOA retry: 900
  SOA expire: 1209600
  SOA minimum: 3600
  BIND update policy: grant YTESTRELM.TEST krb5-self * A; grant YTESTRELM.TEST krb5-self * AAAA; grant YTESTRELM.TEST krb5-self * SSHFP;
  Dynamic update: FALSE
  Allow query: any;
  Allow transfer: none;

[root@master73 ~]# ipa realmdomains-show
  Domain: ytestrelm.test, newzone.test

[root@master73 ~]# ipa realmdomains-mod --del-domain=newzone.test
  Domain: ytestrelm.test

[root@master73 ~]# ipa realmdomains-mod --add-domain=newzone.test
ipa: ERROR: invalid 'domain': The realm of the following domains could not be detected: newzone.test. If these are domains that belong to the this realm, please create a _kerberos TXT record containing "YTESTRELM.TEST" in each of them.

[root@master73 ~]# ipa realmdomains-mod --add-domain=newzone.test --force
  Domain: ytestrelm.test, newzone.test

[root@master73 ~]# ipa realmdomains-mod --del-domain=newzone.test
  Domain: ytestrelm.test
Comment 10 errata-xmlrpc 2016-11-04 01:46:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.