Bug 1258629 - Undercloud install with relative certificate path fails [NEEDINFO]
Undercloud install with relative certificate path fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Ben Nemec
Shai Revivo
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 16:26 EDT by Jeremy
Modified: 2016-10-17 04:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-17 04:19:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bnemec: needinfo? (jmelvin)


Attachments (Terms of Use)
errors (6.30 KB, text/plain)
2015-08-31 16:26 EDT, Jeremy
no flags Details
undercloud.conf (5.16 KB, text/plain)
2015-08-31 16:27 EDT, Jeremy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 245195 None None None Never

  None (edit)
Description Jeremy 2015-08-31 16:26:42 EDT
Created attachment 1068746 [details]
errors

Description of problem:
Undercloud install fails


Version-Release number of selected component (if applicable): 7.0


How reproducible:100!


Steps to Reproduce:
1.use undercloud.conf attached
2.run undercloud install
3.

Actual results:
fails to install

Expected results:
installed correctlly

Additional info:
attached error logs and undercloud.conf
Comment 3 Jeremy 2015-08-31 16:27:07 EDT
Created attachment 1068747 [details]
undercloud.conf
Comment 5 Ben Nemec 2015-09-02 18:16:36 EDT
I would need to see the haproxy logs to say for sure, but I think what is likely happening here is that a relative path for the certificate doesn't work.  I believe that value is written directly to the haproxy config, and it won't be running in the same directory as the install process.

So the first step would be to put the full absolute path to the certificate file in undercloud.conf and try the install again.  I will also look into making the installer handle relative paths correctly.
Comment 6 Ben Nemec 2015-09-03 11:43:32 EDT
I confirmed that relative paths to the certificate do not work, and pushed the linked fix to instack-undercloud to address that going forward.  In the meantime, absolute paths will be necessary.
Comment 7 Mike Burns 2016-04-07 16:47:27 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 9 Dmitry Tantsur 2016-10-17 04:19:33 EDT
This seems to be fixed long time ago.

Note You need to log in before you can comment on or make changes to this bug.