Bug 1258631 - tuskar deployments fail when ceph is set to 0 nodes
tuskar deployments fail when ceph is set to 0 nodes
Status: CLOSED DUPLICATE of bug 1253628
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 16:29 EDT by wes hayutin
Modified: 2016-04-18 02:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 22:00:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
undercloud logs (13.65 MB, application/x-gzip)
2015-08-31 16:29 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2015-08-31 16:29:49 EDT
Created attachment 1068749 [details]
undercloud logs

Description of problem:

"explanation": "The server could not comply with the request since it is either malformed or otherwise incorrect.", "code": 400, "error": {"message": "Property error : CephClusterConfig: ceph_storage_count The Parameter (Ceph-Storage-1::CephStorageCount) was not provided.", "traceback": "Traceback (most recent call last):\n\n  File \"/usr/lib/python2.7/site-packages/heat/common/context.py\", line 300, in wrapped\n    return func(self, ctx, *args, **kwargs)\n\n  File \"/usr/lib/python2.7/site-packages/heat/engine/service.py\", line 669, in create_stack\n    parent_resource_name)\n\n  File \"/usr/lib/python2.7/site-packages/heat/engine/service.py\", line 577, in _parse_template_and_validate_stack\n    stack.validate()\n\n  File \"/usr/lib/python2.7/site-packages/osprofiler/profiler.py\", line 105, in wrapper\n    return f(*args, **kwargs)\n\n  File \"/usr/lib/python2.7/site-packages/heat/engine/stack.py\", line 598, in validate\n    raise ex\n\nStackValidationFailed: Property error : CephClusterConfig: ceph_storage_count The Parameter (Ceph-Storage-1::CephStorageCount) was not provided.\n", "type": "StackValidationFailed"}, "title": "Bad Request"}

[2015-08-31 14:45:25,135] ERROR    openstack ERROR: Property error : CephClusterConfig: ceph_storage_count The Parameter (Ceph-Storage-1::CephStorageCount) was not provided.
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 295, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 53, in run
    self.take_action(parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 826, in take_action
    self._deploy_tuskar(stack, parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 574, in _deploy_tuskar
    parsed_args.timeout)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 430, in _heat_deploy
    orchestration_client.stacks.create(**stack_args)
  File "/usr/lib/python2.7/site-packages/heatclient/v1/stacks.py", line 134, in create
    data=kwargs, headers=headers)
  File "/usr/lib/python2.7/site-packages/heatclient/common/http.py", line 265, in json_request
    resp = self._http_request(url, method, **kwargs)
  File "/usr/lib/python2.7/site-packages/heatclient/common/http.py", line 220, in _http_request
    raise exc.from_response(resp)
HTTPBadRequest: ERROR: Property error : CephClusterConfig: ceph_storage_count The Parameter (Ceph-Storage-1::CephStorageCount) was not provided.
[2015-08-31 14:45:25,137] DEBUG    openstackclient.shell clean_up DeployOvercloud
[2015-08-31 14:45:25,137] DEBUG    openstackclient.shell got an error: ERROR: Property error : CephClusterConfig: ceph_storage_count The Parameter (Ceph-Storage-1::CephStorageCount) was not provided.
[2015-08-31 14:45:25,138] ERROR    openstackclient.shell Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/openstackclient/shell.py", line 176, in run
    return super(OpenStackShell, self).run(argv)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 230, in run
    result = self.run_subcommand(remainder)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 295, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 53, in run
    self.take_action(parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 826, in take_action
    self._deploy_tuskar(stack, parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 574, in _deploy_tuskar
    parsed_args.timeout)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 430, in _heat_deploy
    orchestration_client.stacks.create(**stack_args)
  File "/usr/lib/python2.7/site-packages/heatclient/v1/stacks.py", line 134, in create
    data=kwargs, headers=headers)
  File "/usr/lib/python2.7/site-packages/heatclient/common/http.py", line 265, in json_request
    resp = self._http_request(url, method, **kwargs)
  File "/usr/lib/python2.7/site-packages/heatclient/common/http.py", line 220, in _http_request
    raise exc.from_response(resp)
HTTPBadRequest: ERROR: Property error : CephClusterConfig: ceph_storage_count The Parameter (Ceph-Storage-1::CephStorageCount) was not provided.
Comment 3 wes hayutin 2015-08-31 16:30:34 EDT
deploy command

source /home/stack/stackrc; openstack overcloud deploy --debug --log-file overcloud_deployment_0.log --plan overcloud --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server 10.5.26.10 --control-scale 3 --compute-scale 1 --ceph-storage-scale 0 --block-storage-scale 0 --swift-storage-scale 0 --control-flavor baremetal --compute-flavor baremetal --ceph-storage-flavor baremetal --block-storage-flavor baremetal --swift-storage-flavor baremetal -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/net-single-nic-with-vlans.yaml -e ~/network-environment.yaml -e ~/plan-parameter-neutron-bridge.yaml &> overcloud_deployment_console.log
Comment 5 Mike Burns 2015-08-31 22:00:54 EDT

*** This bug has been marked as a duplicate of bug 1253628 ***

Note You need to log in before you can comment on or make changes to this bug.