Bug 1258654 - RFE: Extend check_rebuild() in kdumpctl to trigger a kdump initramfs image rebuild if the dump device UUID has changed.
RFE: Extend check_rebuild() in kdumpctl to trigger a kdump initramfs image re...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Pratyush Anand
Qiao Zhao
: FutureFeature
Depends On:
Blocks: 1203710 1296180
  Show dependency treegraph
 
Reported: 2015-08-31 19:01 EDT by nyelle@redhat.com
Modified: 2017-08-30 01:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.7-40.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:54:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nyelle@redhat.com 2015-08-31 19:01:10 EDT
The kdump service recreates the initial ramdisk automatically if the configuration or one of the listed files has changed. We use the legacy device names in our configuration and dracut converts the legacy names to UUIDs during creating the initial ramdisk. The UUID of swap devices is changing during re-setup the swap device. kdumpctl doesn't detect this change and doesn't recreate the init ramdisk in such case.

   So the customer would like kdump to trigger an initramfs image rebuild if the devices referenced in an unchanged kdump.conf have changed (i.e. rebuilding kdump initramfs image only on changed kdump.conf modification time is insufficient).
Comment 11 Pratyush Anand 2016-03-29 08:24:57 EDT
Hi Nick,

(In reply to nyelle@redhat.com from comment #0)
>    So the customer would like kdump to trigger an initramfs image rebuild if
> the devices referenced in an unchanged kdump.conf have changed (i.e.
> rebuilding kdump initramfs image only on changed kdump.conf modification
> time is insufficient).

Will it be possible by customer to test kexec-tools from the following brewbuild?

https://brewweb.devel.redhat.com/taskinfo?taskID=10742723

~Pratyush
Comment 13 nyelle@redhat.com 2016-03-31 10:45:40 EDT
@Pratyush,

Customer confirms kexec-tools-2.0.7-38.el7.x86_64 resolves the issue. Thanks again!
Comment 14 Pratyush Anand 2016-05-24 06:20:11 EDT
Patches have been re-posted to RHEL7.3.

http://post-office.corp.redhat.com/archives/kexec-kdump-list/2016-May/msg00022.html
Comment 16 Pratyush Anand 2016-06-28 02:21:16 EDT
Failed QA.

May generate warning like
"Kernel dev name of 192.168.122.199:/export/nfs is not found."

    dracut-functions.sh defines a get_persistent_dev(). Earlier, we had another
    local get_persistent_dev() in mkdumprd, however that was moved to
    kdump-lib.sh, so that it can be reused in kdumpctl.
    
    Since, dracut-module-setup.sh (which is dracut's
    99kdumpbase/module-setup.sh) sources kdump-lib.sh. Therefore, once dracut
    will execute 99kdumpbase module, it's own get_persistent_dev() function is
    overwritten by kdump's version. If any other dracut module calls
    get_persistent_dev() thereafter then, kdump's version is executed, which was
    not expected.
Comment 19 errata-xmlrpc 2016-11-04 02:54:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2466.html

Note You need to log in before you can comment on or make changes to this bug.