Bug 1258686 - satellite 6.1.1 Content view filter erratum by Date and Type not excluding kernels
satellite 6.1.1 Content view filter erratum by Date and Type not excluding ke...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.0
Unspecified Unspecified
high Severity high (vote)
: GA
: --
Assigned To: Justin Sherrill
Katello QA List
: Triaged
Depends On:
Blocks: 1317008 1328298
  Show dependency treegraph
 
Reported: 2015-08-31 21:42 EDT by jnikolak
Modified: 2017-06-26 10:27 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1328298 (view as bug list)
Environment:
Last Closed: 2016-07-27 07:01:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2112571 None None None 2016-01-05 10:58 EST

  None (edit)
Description jnikolak 2015-08-31 21:42:11 EDT
Reproduce Steps


1) publish a content view with no filters
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Provisioning_Guide/sect-Red_Hat_Satellite-Provisioning_Guide-Content_Management_and_Promotion-Publishing_a_Content_View.html

2) Go to Content -> Content View -> YourContentViewName 

3) Click on tab yum content -> Filters -> New Filter

4) Fill out following and then click save
 - Name:
 - Content Type: Erratum by Date and Type
 - Type: Exclude

5) This will take you to Erratum Date Range Tab:
- Ensure tickboxes are selected for: 
  - Security
  - Enhancement   
  - Bugfix

6) Choose a Start Date by clicking on the calendar. 
30-April-2015
The content View Filter will now created.

Then Save



7) Go to Content -> Content Search
8) In Content Dropdown select Packages
9) Enter the Content view Name in "Content View" 
10) In Packages, type name kernel* 

Then click search

The results will show that kernel packages after the date of 30- April 2015
--> 2.6.32-572.el6.x86_64


Why is this kernel package being shown?


I've downloaded both version and based on the build date of the 572 kernel.
It should not be included.



rpm -qip kernel-2.6.32-504.16.2.el6.x86_64.rpm 
Name        : kernel                       Relocations: (not relocatable)
Version     : 2.6.32                            Vendor: Red Hat, Inc.
Release     : 504.16.2.el6                  Build Date: Wed 11 Mar 2015 05:35:02 AM CST
Install Date: (not installed)               Build Host: x86-028.build.eng.bos.redhat.com
Group       : System Environment/Kernel     Source RPM: kernel-2.6.32-504.16.2.el6.src.rpm
Size        : 130003486                        License: GPLv2
Signature   : RSA/8, Fri 17 Apr 2015 10:16:35 AM CST, Key ID 199e2f91fd431d51
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.kernel.org/
Summary     : The Linux kernel
Description :
The kernel package contains the Linux kernel (vmlinuz), the core of any
Linux operating system.  The kernel handles the basic functions
of the operating system: memory allocation, process allocation, device
input and output, etc.


rpm -qip kernel-2.6.32-572.el6.x86_64.rpm 
Name        : kernel                       Relocations: (not relocatable)
Version     : 2.6.32                            Vendor: Red Hat, Inc.
Release     : 572.el6                       Build Date: Tue 23 Jun 2015 03:38:05 PM CST
Install Date: (not installed)               Build Host: x86-028.build.eng.bos.redhat.com
Group       : System Environment/Kernel     Source RPM: kernel-2.6.32-572.el6.src.rpm
Size        : 132425236                        License: GPLv2
Signature   : RSA/8, Wed 24 Jun 2015 04:26:32 PM CST, Key ID 199e2f91fd431d51
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.kernel.org/
Summary     : The Linux kernel
Description :
The kernel package contains the Linux kernel (vmlinuz), the core of any
Linux operating system.  The kernel handles the basic functions
of the operating system: memory allocation, process allocation, device
input and output, etc.
Comment 3 Bryan Kearney 2015-12-10 17:13:57 EST
Clearing the flags to make sure it gets triaged.
Comment 4 Jorgen Langgat 2016-01-04 07:58:57 EST
I see the same bug in Satellite 6.1.5.
Comment 5 Jorgen Langgat 2016-01-18 03:00:49 EST
Found a couple more packages that will need to be filtered manually, as a workaround:

lvm2-2.02.111-2.el6_6.5 - Buildtime   : Wed Jul 29 16:43:20 2015
kernel-firmware-2.6.32-572 - Buildtime   : Tue Jun 23 10:44:35 2015
device-mapper-1.02.90-2.el6_6.5 - Buildtime   : Wed Jul 29 16:43:20 2015

device-mapper-event-1.02.90-2.el6_6.5 - Buildtime   : Wed Jul 29 16:43:20 2015
device-mapper-event-libs-1.02.90-2.el6_6.5 - Buildtime   : Wed Jul 29 16:43:20 2015
device-mapper-libs-1.02.90-2.el6_6.5 - Buildtime   : Wed Jul 29 16:43:20 2015


I got these packages even though I have a filter on 2015-01-29
Comment 9 Chris Roberts 2016-02-22 23:28:02 EST
why was this particular kernel package omitted from the filter? What properties does if have that causes it to be included?
Comment 12 Justin Sherrill 2016-05-12 11:54:36 EDT
Those packages were released on the cdn but were not referenced by any errata.  Those packages have since been removed from the cdn, but may remain on an already synced Satellite.

Please contact support for a method of manually removing those files, or wait until Satellite 6.2 and use the "Mirror on sync' feature to remove them automatically upon sync.

Moving to on_qa for verification that it no longer is an issue.
Comment 13 jcallaha 2016-07-12 09:05:09 EDT
Verified in Satellite 6.2 Beta Snap 19.1

After creating a filter as per above, i see no packages included after the start date specified.
Comment 14 Bryan Kearney 2016-07-27 07:01:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501
Comment 15 Jiri Vavra 2017-01-19 05:35:51 EST
Notes for resolving the issue when other solutions are not working:

e.g. kernel-2.6.32-572.el6.x86_64 is in repository but is not linked to any errata, therefore, Content View which excludes errata newer than ... doesn't work properly

- Mirror on sync might not work
- Remove the package directly from Satellite is not recommended solution, as it's difficult and not safe to do so (package info is spread about more databases, etc.)
- filtering the package version itself might not work (see bug https://bugzilla.redhat.com/show_bug.cgi?id=1395642 )

- probably best possible approach is to make new filter which exclude packages with lower/higher version than ... to meet the problematic package version

Note You need to log in before you can comment on or make changes to this bug.