Bug 125869 - Kdenetwork menu entries should be changed
Kdenetwork menu entries should be changed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-12 17:44 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 19:43:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-06-12 17:44:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
The kdenetwork menu entries are not GNOME HIG compliant.
Please change them like this (or similarly):

Kopete -> Kopete Instant Messenger
KPPP -> KPPP Dial-Up
Ksirc -> KSirc IRC Client
Kget -> KGet Download Manager
KDict -> KDict Online Dictionary

..and any others I've missed



Version-Release number of selected component (if applicable):
kdenetwork-3.2.2-1

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:
Comment 1 Ivan Gyurdiev 2004-06-13 16:02:26 EDT
Relevant:

Gnome Icons, Gnome/KDE Menus need improvement

on fedora-devel
Comment 2 Ngo Than 2004-07-01 07:10:55 EDT
is it not better if we add the description in "()" like:
Kopete -> Kopete (Instant Messenger)
KPPP -> KPPP (Dial-Up)

KDE already has support this feature. i will enable it by default in
next rebuilt.
Comment 3 Ivan Gyurdiev 2004-07-02 21:38:54 EDT
Personally I don't care - but I thought it was important to include
the program function since I have absolutely no idea what all those
KDE programs do - it doesn't help that I use GNOME but I shouldn't
have to try each one to find out.

However, to be consistent with everyone else the function should be
appended, not placed in ( ). That's what the HIG says. 

It's your call I guess. Close the bug if you disagree.

Comment 4 Ivan Gyurdiev 2004-07-21 17:23:34 EDT
Actually the solution that was finally decided upon for GNOME was as
follows: 

The .desktop file will hold:
Name = <appname> <function> 
Generic Name = <function>

Then the menu will be made smart to distinguish apps that are part of
the desktop environment and apps that are not, and display the appname
only for non-core apps. There was a discussion about this on
fedora-desktop. 

As far as KDE is concerned, I don't know what the menu should do,
but since the .desktop file should be standard and shared between
GNOME and KDE, I think all the kdeutils .desktop entries should be
changed accordingly.

By the way, Name is not simply appended to GenericName, because of
translation issues with this approach.
Comment 5 Ivan Gyurdiev 2004-11-24 19:43:23 EST
I'll assume:

1) This issue has been dealt with when all the other
menu entries were fixed, or

2) You won't deal with it, because freedesktop policies do not
apply to KDE.

Either way, I don't care anymore, and I'm closing all my
ancient bugs.

Note You need to log in before you can comment on or make changes to this bug.