Bug 125870 - Kdeutils menu entries should be changed
Summary: Kdeutils menu entries should be changed
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-12 21:58 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 00:42:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivan Gyurdiev 2004-06-12 21:58:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
The kdeutils menu entires are not GNOME HIG compliant.
Please change them like this (or similarly):

Kgpg -> Kgpg Encryption
Khexedit -> KHexEdit Binary Editor
Ktimer -> KTimer Task Scheduler
KwikDisk -> KwikDisk Removable Media

etc... 





Version-Release number of selected component (if applicable):
kdeutils-3.2.2-3

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:

Comment 1 Ivan Gyurdiev 2004-06-13 20:02:05 UTC
Relevant:

Gnome Icons, Gnome/KDE Menus need improvement

on fedora-devel

Comment 2 Ivan Gyurdiev 2004-07-21 21:19:22 UTC
Actually the solution that was finally decided upon for GNOME was as
follows: 

The .desktop file will hold:
Name = <appname> <function> 
Generic Name = <function>

Then the menu will be made smart to distinguish non-core from core
apps and display the appname only for non-core apps. There was a
discussion about this on fedora-desktop. 

Now, as far as KDE is concerned, I don't know what the menu should do,
but since the .desktop file should be standard and shared between
GNOME and KDE, I think all the kdeutils .desktop entries should be
changed accordingly.

By the way, Name is not simply appended to GenericName, because of
translation issues with this approach.

Comment 3 Ivan Gyurdiev 2004-07-21 21:21:47 UTC
By core and non-core I mean part of the desktop environment and not
part of the desktop environment. Anyway, I don't know how that applies
to KDE, but I'm pretty sure the .desktop entries should be changed
like this.

  



Comment 4 Ivan Gyurdiev 2004-11-25 00:42:20 UTC
I'll assume:

1) This issue has been dealt with when all the other
menu entries were fixed, or

2) You won't deal with it, because freedesktop policies do not
apply to KDE.

Either way, I don't care anymore, and I'm closing all my
ancient bugs. 


Note You need to log in before you can comment on or make changes to this bug.