This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1258704 - nodejs-typeahead.js-v0.11.1 is available
nodejs-typeahead.js-v0.11.1 is available
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nodejs-typeahead.js (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Callaghan
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 00:26 EDT by Upstream Release Monitoring
Modified: 2015-09-01 01:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 01:05:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2015-09-01 00:26:11 EDT
Latest upstream release: v0.11.1
Current version/release in rawhide: 0.10.5-3.fc23
URL: http://twitter.github.com/typeahead.js

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-09-01 00:26:16 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-opxikm/nodejs-typeahead.js.spec
return code:  22
stdout:
Getting http://registry.npmjs.org/typeahead.js/-/typeahead.js-v0.11.1.tgz to ./typeahead.js-v0.11.1.tgz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 2 Dan Callaghan 2015-09-01 01:01:52 EDT
Sigh... upstream claims to follow semver but then notes in the changelog for 0.11.0:

"There are bunch of API changes with this release so don't expect backwards compatibility with previous versions."

and

"Beware that since this release is pretty much a rewrite, there are bound to be some bugs. To be safe, you should consider this release beta software and throughly test your integration of it before using it in production environments."

Moreover there has not been any bug fix releases since 0.11.0 on 25 April and 0.11.1 on 26 April, and I'm not confident that the project is still actively maintained by its author given the state of its Github issue tracker.

So I am wondering if it's really a good idea to bump this package to 0.11.1 or not...
Comment 3 Dan Callaghan 2015-09-01 01:05:56 EDT
This version also introduces a bunch of new unpackaged build dependencies (grunt modules). So I am going to call this WONTFIX for now. If in future it turns out that 0.11 is needed for some other projects and/or upstream shows more signs of life, I will re-open.

Note You need to log in before you can comment on or make changes to this bug.