Bug 125873 - ATI IXP150 AC 97 doesnt work with fedora core 2
ATI IXP150 AC 97 doesnt work with fedora core 2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-12 20:15 EDT by Nahim de Anda
Modified: 2015-01-04 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nahim de Anda 2004-06-12 20:15:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
My sound card was working using FC1 plus ALSA packages from FRESHRPMS.NET 

Withe FC2 (kernel-2.6.6-1.427) It doesnt work anymore.

This is the outpout of dmesg  after loading the module snd-atiixp :
ATI IXP AC97 controller: probe of 0000:00:14.5 failed with error -13

I've this soud card:

00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97
Audio Controller

My computer is LAPTOP Compaq model R3050US




Version-Release number of selected component (if applicable):
kernel-2.6.6-1.427

How reproducible:
Always

Steps to Reproduce:
1.load kernel module for this card


Actual Results:  Module doesnt work whit the sound card

Expected Results:  This module should work with the sound card

Additional info:

00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97
Audio Controller
Comment 1 CRSolutions 2004-08-03 17:24:38 EDT
It worked fine until version 2.6.5-1.358.
Some kernel modifications caused the problem, which ones ?
 
Comment 2 Michael Grant 2005-01-24 16:01:45 EST
(Found this Bugzilla entry via a websearch.)  I also have Fedora Core
2 (kernel version 2.6.5-1.358smp in my case) and this soundcard, and
sound doesn't work for me either.  I don't get this turning up in
dmesg's output.  I do get the following under the modprobe section of
the daily logwatch email to root:
                                                                       
        
 Errors running install command:
   sound_slot_1  : 2 Time(s)
                                                                       
        
When I tried doing a modprobe for this manually, I got:
 FATAL: Module snd_card_1 not found.
 FATAL: Error running install command for sound_slot_1
                                                                       
        
This is what _does_ load:
                                                                       
        
[root@epicyclic etc]# lsmod | grep nd
snd_mixer_oss          17792  2
snd_atiixp             16932  3
snd_ac97_codec         54916  1 snd_atiixp
snd_pcm                76420  1 snd_atiixp
snd_timer              22404  1 snd_pcm
snd_page_alloc         12036  2 snd_atiixp,snd_pcm
snd                    43876  7
snd_mixer_oss,snd_atiixp,snd_ac97_codec,snd_pcm,snd_timer
soundcore              10336  3 snd
                                                                       
        
I'm not sure if it's relevant, but I also get, on starting booting:
  ACPI: S3 and PAE do not like each other for now, S3 disabled.
                                                                       
        
I did a websearch on this a while back, the results of which
recommended adding "noapic acpi=irq" to my boot kernel parameters, but
that didn't have any effect.
                                                                       
        
Can you help me?
Comment 3 Dave Jones 2005-04-16 00:13:37 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.