Bug 1258745 - realm command line utility does not write logs about package installation to srdout/stderr
realm command line utility does not write logs about package installation to ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: realmd (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Sumit Bose
Patrik Kis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 03:44 EDT by Patrik Kis
Modified: 2016-11-04 03:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: realmd-0.16.1-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 03:46:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrik Kis 2015-09-01 03:44:51 EDT
Description of problem:
The previous version of realm command line utility used to write logs about package installation (via PackageKit) to stdout/stderr. Now this changed and can be considered as regression (although with very low priority as logging to journal still works).
I'm not sure, maybe this is caused by recent API change in PackageKit and realmd rebase, but rather reporting the issue here.

Version-Release number of selected component (if applicable):
realmd-0.16.1-3.el7
PackageKit-1.0.7-4.el7

How reproducible:
always

Steps to Reproduce:

# yum -y install PackageKit
...snip
# yum -y remove  sssd sssd-common adcli
...snip
# realm join --user=admin <AD_DOMAIN>
Password for admin: 
#

Expected results:

# realm join --user=admin <AD_DOMAIN>
Password for Amy-admin: 
 * Installing necessary packages: adcli, sssd
#
Comment 2 Stef Walter 2015-09-07 06:55:23 EDT
This is a oneline fix, which I've now pushed upstream:

http://cgit.freedesktop.org/realmd/realmd/commit/?id=ef0797e5ed116a98cc074a6d4e1d1d6b6e6384db

Please let me know if I should respin the errata for this.
Comment 5 Stef Walter 2015-09-10 05:47:28 EDT
Patrick could you add the exception request to this bug?
Comment 10 Stef Walter 2015-10-02 08:59:40 EDT
Bug dropped from RHEL 7.2 as discussed in bug #1267563
Comment 16 errata-xmlrpc 2016-11-04 03:46:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2511.html

Note You need to log in before you can comment on or make changes to this bug.