Bug 1258751 - Balancing not take in account vms that have specific host to run
Balancing not take in account vms that have specific host to run
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.6.0
All Linux
unspecified Severity high (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Martin Sivák
Artyom
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 04:03 EDT by Artyom
Modified: 2016-02-18 06:15 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Balancing limited migratable VMs selection to VMs that are running, support migration and have no pinning. Unfortunately the pinning configuration is shared with preferred host configuration and we had a bug there. Consequence: VMs with preferred host set could not be balanced. Fix: The coupling between pinning and preferred was removed in balancing. Result: A VM with preferred host can be balanced if it supports migration and is not hard-pinned.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:15:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
msivak: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45559 master MERGED core: allow to balance migrate vm that run on specific host 2016-01-26 02:31 EST
oVirt gerrit 52739 ovirt-engine-3.6 MERGED core: allow to balance migrate vm that run on specific host 2016-01-27 04:05 EST

  None (edit)
Description Artyom 2015-09-01 04:03:22 EDT
Description of problem:
Balancing not take in account vms that have specific host to run

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.12.master.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have two hosts without CPU loading(host_1, host_2)
2. Run once vm_1 with specific host_1 and Run once vm_2 with specific host_2(each vm have one GB of memory)
3. Load one host CPU to 50%(host_1)
4. Change cluster policy to power saving with parameters:
   Low Utilization: 20
   High Utilization: 80
   CpuOverCommitmentDuration: 1
5. Wait 5 minutes


Actual results:
No migration happen from host_2 to host_1

Expected results:
Vm from host_2 must be migrated by balancing to host_1

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2016-01-26 02:38:58 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Sandro Bonazzola 2016-01-27 08:46:25 EST
Martin, this bug is on modified and referenced in ovirt engine 3.6.3 git logs but targeted 3.6.5. Can you check?
Comment 3 Martin Sivák 2016-01-27 09:23:42 EST
Well I guess we should retarget it as it was already merged :)
Comment 4 Artyom 2016-02-01 08:18:04 EST
Verified on rhevm-backend-3.6.3-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.