Bug 1258758 - [engine-image-uploader] Misleading error msg when wrong path for image is used
[engine-image-uploader] Misleading error msg when wrong path for image is used
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-image-uploader (Show other bugs)
Unspecified Unspecified
medium Severity low
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Rafael Martins
: EasyFix
Depends On:
  Show dependency treegraph
Reported: 2015-09-01 04:28 EDT by Gonza
Modified: 2016-03-09 15:01 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when using the image uploader tool (ovirt-image-uploader) to upload an image, if an incorrect path to the image was provided, a misleading error message was returned. With this update, a more meaningful error message is returned.
Story Points: ---
Clone Of:
Last Closed: 2016-03-09 15:01:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46192 master MERGED ovirt-image-uploader: show informative msg if OVF data not found Never
oVirt gerrit 46371 ovirt-image-uploader-3.6 MERGED ovirt-image-uploader: show informative msg if OVF data not found Never

  None (edit)
Description Gonza 2015-09-01 04:28:26 EDT
Description of problem:
Tried uploading an image to export domain with an incorrect path to the image file and got the following error msg displayed:
ERROR: not a gzip file
This could be misleading as this same error msg would be displayed when trying to upload an ovf image generated from VirtualBox.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run "engine-image-uploader -e {export_domain_name} upload foo"

Actual results:
Misleading error msg is displayed:
"ERROR: not a gzip file"

Expected results:
More accurate error msg should be displayed. 

Additional info:
Suggestion: "ERROR: file does not exist"
Comment 2 Gonza 2015-10-07 09:22:15 EDT
Verified with:

Output now shows:
ERROR: OVF data not found: foo
Must be a gzip-compressed file or a directory.
Comment 4 errata-xmlrpc 2016-03-09 15:01:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.