This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1258764 - "sortby ip" will not work if a vm has two vNICs and two IPs
"sortby ip" will not work if a vm has two vNICs and two IPs
Status: CLOSED DUPLICATE of bug 1164235
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.5.0
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Vinzenz Feenstra [evilissimo]
sefi litmanovich
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 04:50 EDT by wwu@redhat.com
Modified: 2016-02-09 20:31 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 05:20:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
one nic,one ip (218.05 KB, image/png)
2015-09-01 04:50 EDT, wwu@redhat.com
no flags Details
one-nic-sortbyip (256.94 KB, image/png)
2015-09-01 04:50 EDT, wwu@redhat.com
no flags Details
two-nics&IPs (217.87 KB, image/png)
2015-09-01 04:51 EDT, wwu@redhat.com
no flags Details
two-nics-sortbyip (251.67 KB, image/png)
2015-09-01 04:52 EDT, wwu@redhat.com
no flags Details

  None (edit)
Description wwu@redhat.com 2015-09-01 04:50:13 EDT
Created attachment 1068883 [details]
one nic,one ip

I've done a test:
Normally ,rhev can show vms' ip after installing rhev guest agent on the vms.And we could alos use 'sortby ip' to sort vms.(refer to the images "one-nic.png" and "one-nic-sortbyip.png").

But if a vm has two vnics ,we can't use 'sortby ip' normally..(refer to 'two-nic&IPs.png' and 'two-nics-sortbyip.png')

It is easy to reproduce in RHEV(3.3/3.5).I didn't test that in RHEV3.4

Regards
Victor
Comment 1 wwu@redhat.com 2015-09-01 04:50:59 EDT
Created attachment 1068884 [details]
one-nic-sortbyip
Comment 2 wwu@redhat.com 2015-09-01 04:51:41 EDT
Created attachment 1068885 [details]
two-nics&IPs
Comment 3 wwu@redhat.com 2015-09-01 04:52:15 EDT
Created attachment 1068886 [details]
two-nics-sortbyip
Comment 4 Omer Frenkel 2015-09-02 05:20:15 EDT
fixed in 3.6 for more info please see bug 1164235

*** This bug has been marked as a duplicate of bug 1164235 ***

Note You need to log in before you can comment on or make changes to this bug.