Bug 1258774 - gnumeric-1.12.23-1.fc24.src.rpm FTBFS: failed to load "../icons/16x16/actions/gnumeric-cells-merge.xpm": Couldn't recognize the image file format for file '../icons/16x16/actions/gnumeric-cells-merge.xpm'
gnumeric-1.12.23-1.fc24.src.rpm FTBFS: failed to load "../icons/16x16/actions...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks: 1272070
  Show dependency treegraph
 
Reported: 2015-09-01 05:15 EDT by Petr Pisar
Modified: 2015-11-19 13:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 13:54:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-09-01 05:15:33 EDT
gnumeric-1.12.23-1.fc24.src.rpm fails to build in F24:

make[2]: Entering directory '/builddir/build/BUILD/gnumeric-1.12.23/src'
glib-genmarshal --prefix=gnm_ --header gnm-marshalers.list >gnm-marshalers.h
creating gnumeric-paths.h
  GEN      gnmresources.c
  GEN      gnmresources.h
failed to load "../icons/16x16/actions/gnumeric-cells-merge.xpm": Couldn't recognize the image file format for file '../icons/16x16/actions/gnumeric-cells-merge.xpm'
failed to load "../icons/16x16/actions/gnumeric-cells-merge.xpm": Couldn't recognize the image file format for file '../icons/16x16/actions/gnumeric-cells-merge.xpm'
gnm.gresource.xml: Child process exited with code 1.
gnm.gresource.xml: Child process exited with code 1.
Makefile:2636: recipe for target 'gnmresources.h' failed

Difference between working and failing build root:

        gtk3 	3.17.5-1.fc24 	> 	3.17.6-1.fc24
	gtk3-devel 	3.17.5-1.fc24 	> 	3.17.6-1.fc24
	gdk-pixbuf2 	2.31.5-1.fc24 	> 	2.31.5-2.fc24
	librsvg2-devel 	2.40.9-2.fc23 	> 	2.40.9-3.fc24
	gtk-update-icon-cache 	3.17.5-1.fc24 	> 	3.17.6-1.fc24
	gdk-pixbuf2-devel 	2.31.5-1.fc24 	> 	2.31.5-2.fc24
	gdk-pixbuf2-modules 	2.31.5-1.fc24 	> 	2.31.5-2.fc24
	librsvg2 	2.40.9-2.fc23 	> 	2.40.9-3.fc24
	kernel-headers 	4.2.0-0.rc5.git0.2.... 	> 	4.2.0-0.rc5.git2.1....
Comment 1 Julian Sikorski 2015-10-26 15:14:48 EDT
Hi Morten,

do you understand what exactly is failing here? I assume it is caused by some bleeding edge upgrade in rawhide, but I am lost where to look.
Comment 2 M Welinder 2015-10-26 19:04:23 EDT
Did the xpm format get dropped or configured out in gdk-pixbuf?
Comment 3 Julian Sikorski 2015-10-28 02:54:26 EDT
It does not look like it. The only change in gdk-pixbuf2 was buildsys related.
Comment 4 M Welinder 2015-10-28 11:21:28 EDT
If you run with "make V=1" you should see that it is failing in a call
to glib-compile-resources.  In my case it is this:

/usr/lib/x86_64-linux-gnu/glib-2.0/glib-compile-resources gnm.gresource.xml \
		--target=gnmresources.c --sourcedir=.. --c-name _gnm --generate-source --manual-register

This failure is clearly not in Gnumeric's code, but in either glib's or gdk-pixbuf's.  Can you CC them here to see if they have an idea?
Comment 5 Julian Sikorski 2015-11-19 13:54:16 EST
Whatever it was causing the build failure, it is gone now.

Note You need to log in before you can comment on or make changes to this bug.