Bug 1258791 - sushi does not preview non utf8 text files
sushi does not preview non utf8 text files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sushi (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 06:06 EDT by Martin Simon
Modified: 2017-08-01 18:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: sushi-3.21.91-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:59:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2151 normal SHIPPED_LIVE sushi bug fix update 2017-08-01 15:39:28 EDT

  None (edit)
Description Martin Simon 2015-09-01 06:06:27 EDT
Description of problem:
I've tried to open some text files and only utf-8 can be displayed. I've tried iso8859-1, iso8859-15, utf-8, utf-16, cp1250 and cp1252.

Version-Release number of selected component (if applicable):
sushi-3.12.0-3.el7.x86_64
nautilus-3.14.3-3.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Select any text file which is not encoded in utf-8
2. Hit space bar

Actual results:
A spinner in sushi window is cycling, and cycling, ...

Expected results:
sushi windows with a scrollable context of sample non utf-8 text file

Additional info:
I've tested the same sample text file with special characters converted to different encodings via iconv
Comment 1 Matthias Clasen 2015-09-18 14:34:10 EDT
This works with upstream sushi, the fix is in

commit 898d8f23538a6b62f73c032be662f53487809e79
Author: Cosimo Cecchi <cosimoc@gnome.org>
Date:   Thu Jun 25 15:07:53 2015 -0700

    text-loader: use GtkSourceFileLoader
    
    Instead of our homebrew implementation, since GtkSourceFileLoader deals
    with non-UTF8 text as well.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=704245
Comment 7 errata-xmlrpc 2017-08-01 18:59:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2151

Note You need to log in before you can comment on or make changes to this bug.