Bug 1258839 - Refresh Power States Fails for OpenStack - No Cinder
Refresh Power States Fails for OpenStack - No Cinder
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.3.0
Unspecified Unspecified
high Severity high
: GA
: 5.4.3
Assigned To: Greg Blomquist
Pete Savage
: ZStream
Depends On: 1217916
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 07:51 EDT by Chris Pelland
Modified: 2015-10-22 10:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.4.3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1217916
Environment:
Last Closed: 2015-10-22 10:33:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2015-09-28 15:08:14 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c90c96fdc0418edf99cca6dd7772cfacbbac6050

commit c90c96fdc0418edf99cca6dd7772cfacbbac6050
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Mon Aug 31 18:04:13 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Tue Sep 1 10:08:57 2015 -0400

    Do not get volumes when cinder isn't available
    
    The openstack inventory parser already has logic in place to avoid getting
    volumes from Cinder if the cinder service is not running.  However, this check
    if bypassed when trying to get the list of Availability Zones.
    
    When the openstack inventory parser tries to get the list of Availability Zones,
    it checks what Availability Zones are assigned to instances as well as which are
    assigned to volumes.  This check for Availability Zones assigned to volumes does
    not take into account the fact that cinder might not be running.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1258839
    https://bugzilla.redhat.com/show_bug.cgi?id=1217916

 vmdb/app/models/ems_refresh/parsers/openstack.rb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
Comment 3 CFME Bot 2015-09-28 15:08:44 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=545aba438035f14f739608af953d744a344485b0

commit 545aba438035f14f739608af953d744a344485b0
Merge: da6ae33 c90c96f
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Mon Sep 28 15:07:16 2015 -0400
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Mon Sep 28 15:07:16 2015 -0400

    Merge branch 'bz1258839-refresh-fails-with-no-cinder' into '5.4.z'
    
    Do not get volumes when cinder isn't available
    
    The openstack inventory parser already has logic in place to avoid getting volumes from Cinder if the cinder service is not running.  However, this check if bypassed when trying to get the list of Availability Zones.
    
    When the openstack inventory parser tries to get the list of Availability Zones, it checks what Availability Zones are assigned to instances as well as which are assigned to volumes.  This check for Availability Zones assigned to volumes does not take into account the fact that cinder might not be running.
    
    Upstream: https://github.com/ManageIQ/manageiq/pull/2845
    
    Backport notes: this code was re-rooted and namespaced ... I just manually applied the changes because the changes were so trivial
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1258839
    https://bugzilla.redhat.com/show_bug.cgi?id=1217916
    
    See merge request !241

 vmdb/app/models/ems_refresh/parsers/openstack.rb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
Comment 7 Dave Johnson 2015-10-13 14:23:24 EDT
Pete, please retest per comment 6  ;)
Comment 8 Pete Savage 2015-10-15 09:45:42 EDT
Verified in 5.4.3.1
Comment 10 errata-xmlrpc 2015-10-22 10:33:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1916.html

Note You need to log in before you can comment on or make changes to this bug.