Bug 1258879 - [RFE] Reduce nova-api load from ceilometer agents with instance metadata caching
[RFE] Reduce nova-api load from ceilometer agents with instance metadata caching
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity urgent
: beta
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
Yurii Prokulevych
https://blueprints.launchpad.net/ceil...
upstream_milestone_liberty-2 upstream...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 08:54 EDT by Eoghan Glynn
Modified: 2016-04-07 17:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-ceilometer-5.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:05:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eoghan Glynn 2015-09-01 08:54:53 EDT
Currently the ceilometer compute & hardware agents impose much unnecessary load on the nova-api service by querying the instance metadata for every local instance on every polling cycle. This load has caused major problems for operators of ceilometer.

The instance metadata is required to decorate the more minimal instance representation retrieved directly from the hypervisor or SNMP, when constructing a classic ceilometer sample (which includes rich snapshotted metadata).

However much of this metadata is either static or very infrequently changing, so could easily be cached within the agent.

So the nova-api load could be significantly reduced by constraining the nova-api query to only report on the subset of instances for the current node that have changed since the last polling cycle (using the 'changes-since' query parameter).
Comment 5 Yurii Prokulevych 2016-02-12 03:51:28 EST
Verified according test plan.
Packages: ceilometer*-5.0.2-1.el7ost.noarch
Comment 7 errata-xmlrpc 2016-04-07 17:05:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.