Bug 1258902 - [abrt] kdelibs: KCrash::defaultCrashHandler(): kdeinit4 killed by SIGSEGV
[abrt] kdelibs: KCrash::defaultCrashHandler(): kdeinit4 killed by SIGSEGV
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kdelibs (Show other bugs)
7.2
aarch64 Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
abrt_hash:24579c9e1d7d7e1500973cd24c1...
:
: 1258824 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 09:48 EDT by Michal Domonkos
Modified: 2015-11-23 11:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 11:19:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (68.18 KB, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details
File: cgroup (177 bytes, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details
File: core_backtrace (7.36 KB, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details
File: dso_list (15.28 KB, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details
File: environ (2.19 KB, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details
File: maps (59.97 KB, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details
File: open_fds (187 bytes, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details
File: proc_pid_status (870 bytes, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details
File: var_log_messages (162 bytes, text/plain)
2015-09-01 09:48 EDT, Michal Domonkos
no flags Details

  None (edit)
Description Michal Domonkos 2015-09-01 09:48:07 EDT
Description of problem:
Logged in to KDE.

Version-Release number of selected component:
kdelibs-4.14.8-4.el7

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        'kdeinit4: plasma-desktop [kdeinit]' '' '' '' '' '' '' '' '' '' '' '' '' ''
crash_function: KCrash::defaultCrashHandler
executable:     /usr/bin/kdeinit4
kernel:         4.2.0-0.rc6.18.el7.aarch64
machineid:      systemd=ae0be727484a49238d1a1e4e39d52a17
runlevel:       N 3
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #1 KCrash::defaultCrashHandler at /usr/src/debug/kdelibs-4.14.8/kdeui/util/kcrash.cpp:352
 #3 value at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSString.h:280
 #4 QTJSC::InternalFunction::name at ../3rdparty/javascriptcore/JavaScriptCore/runtime/InternalFunction.cpp:48
 #5 QTJSC::JSObject::putDirectFunctionWithoutTransition at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSObject.cpp:522
 #6 QTJSC::FunctionPrototype::addFunctionProperties at ../3rdparty/javascriptcore/JavaScriptCore/runtime/FunctionPrototype.cpp:48
 #7 QTJSC::JSGlobalObject::reset at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.cpp:212
 #8 QTJSC::JSGlobalObject::init at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.cpp:151
 #9 JSGlobalObject at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h:168
 #10 QScript::GlobalObject::GlobalObject at bridge/qscriptglobalobject.cpp:45
 #11 QScriptEnginePrivate::QScriptEnginePrivate at api/qscriptengine.cpp:981
Comment 1 Michal Domonkos 2015-09-01 09:48:09 EDT
Created attachment 1069010 [details]
File: backtrace
Comment 2 Michal Domonkos 2015-09-01 09:48:09 EDT
Created attachment 1069011 [details]
File: cgroup
Comment 3 Michal Domonkos 2015-09-01 09:48:10 EDT
Created attachment 1069012 [details]
File: core_backtrace
Comment 4 Michal Domonkos 2015-09-01 09:48:11 EDT
Created attachment 1069013 [details]
File: dso_list
Comment 5 Michal Domonkos 2015-09-01 09:48:12 EDT
Created attachment 1069014 [details]
File: environ
Comment 6 Michal Domonkos 2015-09-01 09:48:13 EDT
Created attachment 1069015 [details]
File: limits
Comment 7 Michal Domonkos 2015-09-01 09:48:14 EDT
Created attachment 1069016 [details]
File: maps
Comment 8 Michal Domonkos 2015-09-01 09:48:15 EDT
Created attachment 1069017 [details]
File: open_fds
Comment 9 Michal Domonkos 2015-09-01 09:48:16 EDT
Created attachment 1069018 [details]
File: proc_pid_status
Comment 10 Michal Domonkos 2015-09-01 09:48:16 EDT
Created attachment 1069019 [details]
File: var_log_messages
Comment 11 Michal Domonkos 2015-09-01 09:49:13 EDT
*** Bug 1258824 has been marked as a duplicate of this bug. ***
Comment 12 Michal Domonkos 2015-09-01 09:51:14 EDT
KDE won't start as a result.
Comment 13 Jan Grulich 2015-09-03 03:27:02 EDT
I tried to do a build of the latest Qt which includes some aarch64 fixes and also backported some other aarch64 fixes from Ubuntu. If that helps, we will need to either update Qt or backport all aarch64 related fixes. Anyway, here is a test build https://brewweb.devel.redhat.com/taskinfo?taskID=9786435.
Comment 14 Michal Domonkos 2015-09-03 05:11:52 EDT
(In reply to Jan Grulich from comment #13)
> I tried to do a build of the latest Qt which includes some aarch64 fixes and
> also backported some other aarch64 fixes from Ubuntu. If that helps, we will
> need to either update Qt or backport all aarch64 related fixes. Anyway, here
> is a test build https://brewweb.devel.redhat.com/taskinfo?taskID=9786435.

Jan,

This build fixes it!  I can successfully login to KDE and everything seems to work fine.
Comment 15 Jan Grulich 2015-09-10 06:34:11 EDT
Fixed in qt-4.8.5-11.el7.
Comment 19 errata-xmlrpc 2015-11-23 11:19:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2282.html

Note You need to log in before you can comment on or make changes to this bug.