Bug 125892 - Gnucash hangs under kde/xcfe when accessing help
Gnucash hangs under kde/xcfe when accessing help
Product: Fedora
Classification: Fedora
Component: gtkhtml (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Depends On:
  Show dependency treegraph
Reported: 2004-06-13 08:20 EDT by Richard Huxton
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-25 17:04:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Installation log from gnucash until it worked (2.01 KB, text/plain)
2004-06-29 03:24 EDT, Richard Huxton
no flags Details

  None (edit)
Description Richard Huxton 2004-06-13 08:20:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040608 Firefox/0.8.0+

Description of problem:
With KDE/xcfe desktop and gnome libs (but *not* gnome desktop nor many
apps) I installed and ran gnucash.
On accessing the help (the manual or tutorial) or reports, gnucash
would hang.

A quick check with strace seemed to show it blocking on accessing a
pipe, and also showed problems finding a gconf file. I downloaded and
installed gnome-desktop and a few dependencies, logged into a gnome
session and all seemed OK.

Returning to xcfe/kde shows the problem is still there, which suggests
it depends on some gnome component running.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start kde/xcfe desktop
2. Run gnucash
3. From the menu choose help/tutorial or help/help

Actual Results:  Gnucash hangs, sometimes with a small "GnuCash Help"
window (empty).

Expected Results:  Help displayed.

Additional info:

Not sure if this is actually a problem with guile or the gnome help
system, since I don't run a lot of gnome apps.
Comment 1 Richard Huxton 2004-06-13 11:50:20 EDT
Following up on my own post...

I think it is something to do with gconf - from memory, it wasn't
running before but is now that I've rebooted my machine, and the
problem has gone away. Previously, I could reproduce it on demand.

I'm guessing if you accept the default install of a Gnome desktop
you'd never notice this, since you'd get the relevant .gconfd
directory setup and so there'd be something there for gnucash to
read/save config in (if that's what it's for).

Presumably, this affects many gnome-based applications.
Comment 2 Bill Nottingham 2004-06-29 00:01:39 EDT
What was it running through the pipe? Was it executing htmlview, or
something else?
Comment 3 Richard Huxton 2004-06-29 03:24:56 EDT
Created attachment 101498 [details]
Installation log from gnucash until it worked
Comment 4 Richard Huxton 2004-06-29 04:00:02 EDT
Can't say, sorry. The only process I can see is:
/usr/bin/guile -e main -s /usr/libexec/gnucash/overrides/gnucash
Opening help doesn't seem to start any new processes, so presumably
it's already running something. Can't see any obvious candidates in my

I've attached the installation log of around the time - the second
group must contain something that enables part of the gnome
infrastructure to run. There is nothing in my /var/log/messages files
that show unusual activity.
From memory, I don't remember gconf running (it's gconfd-1 I can see
in my "ps") but it gets restarted as required if I kill it now.

If I change the ownership of my ~/.gconf ~/.gconfd then I get an error
message saying gtkhtml can't contact the configuration server. This is
_not_ what happened before - it used to just hang. If I delete these
two directories, they get recreated.
Comment 5 Bill Nottingham 2004-06-29 14:28:15 EDT
Assigning to gtkhtml for now; it appears to be something in the
gtkhtml library code.
Comment 6 Matthew Miller 2005-04-26 11:36:55 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 8 John Thacker 2006-10-25 17:04:19 EDT
Closing per lack of response.  Also note that FC1 and FC2 are no longer
supported even by Fedora Legacy.  If this still occurs on FC3 or FC4, please
assign to that version and Fedora Legacy.  If it still occurs on FC5 or FC6,
please reopen and assign to the correct version.

Note that gnucash has changed quite a bit since then; among other things, the
move to gtk2.

Note You need to log in before you can comment on or make changes to this bug.