Bug 1258920 - perl-Log-Dispatch-Config-1.04-10.fc24 FTBFS: tests fail
perl-Log-Dispatch-Config-1.04-10.fc24 FTBFS: tests fail
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Log-Dispatch-Config (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 10:21 EDT by Petr Pisar
Modified: 2015-09-21 12:42 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.04-8.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 06:51:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 106746 None None None Never

  None (edit)
Description Petr Pisar 2015-09-01 10:21:38 EDT
perl-Log-Dispatch-Config-1.04-10.fc24 fails to build in F24:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00_compile.t ....... ok
t/01_configure.t ..... ok
# Looks like your test exited with 25 before it could output anything.
t/02_log.t ........... 
Dubious, test returned 25 (wstat 6400, 0x1900)
Failed 4/4 subtests 
t/03_reload.t ........ ok
t/04_nolog.t ......... ok
t/05_compat.t ........ ok
t/06_configurator.t .. ok
t/07_hardwired.t ..... ok
20150830 debug Sun Aug 30 18:56:46 2015
#   Failed test at t/08_datetime.t line 19.
#                   undef
#     doesn't match '(?^:20150830)'
#   Failed test at t/08_datetime.t line 20.
#                   undef
#     doesn't match '(?^:debug)'
# Looks like you failed 2 tests of 3.
t/08_datetime.t ...... 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/3 subtests 
t/09_ini.t ........... ok
t/10_caller.t ........ ok
t/11_no_watch.t ...... ok
t/12_inherit.t ....... ok
t/13_do_reload.t ..... ok
t/14_destroy.t ....... ok
t/15_appconfig.t ..... ok
Test Summary Report
-------------------
t/02_log.t         (Wstat: 6400 Tests: 0 Failed: 0)
  Non-zero exit status: 25
  Parse errors: Bad plan.  You planned 4 tests but ran 0.
t/08_datetime.t    (Wstat: 512 Tests: 3 Failed: 2)
  Failed tests:  2-3
  Non-zero exit status: 2
Files=16, Tests=47,  4 wallclock secs ( 0.05 usr  0.03 sys +  0.89 cusr  0.11 csys =  1.08 CPU)
Result: FAIL

Difference between working and failing build root is:

        perl-Log-Dispatch 	2.44-3.fc23 	> 	2.48-1.fc24
	nss-softokn-freebl 	3.19.2-2.fc23 	> 	3.19.3-2.fc24
	nss-sysinit 	3.19.2-3.fc23 	> 	3.19.3-2.fc24
	nss-util 	3.19.2-2.fc23 	> 	3.19.3-2.fc24
	nss-tools 	3.19.2-3.fc23 	> 	3.19.3-2.fc24
	nss-softokn 	3.19.2-2.fc23 	> 	3.19.3-2.fc24
	nss 	3.19.2-3.fc23 	> 	3.19.3-2.fc24
Comment 1 Fedora Update System 2015-09-02 08:24:42 EDT
perl-Log-Dispatch-Config-1.04-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14859
Comment 2 Fedora Update System 2015-09-02 08:27:12 EDT
perl-Log-Dispatch-Config-1.04-9.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14860
Comment 3 Fedora Update System 2015-09-02 08:30:12 EDT
perl-Log-Dispatch-Config-1.04-8.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14864
Comment 4 Fedora Update System 2015-09-03 05:52:40 EDT
perl-Log-Dispatch-Config-1.04-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update perl-Log-Dispatch-Config'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14859
Comment 5 Fedora Update System 2015-09-03 15:19:00 EDT
perl-Log-Dispatch-Config-1.04-8.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update perl-Log-Dispatch-Config'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14864
Comment 6 Fedora Update System 2015-09-03 15:20:52 EDT
perl-Log-Dispatch-Config-1.04-9.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update perl-Log-Dispatch-Config'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14860
Comment 7 Fedora Update System 2015-09-21 06:51:09 EDT
perl-Log-Dispatch-Config-1.04-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-09-21 09:18:03 EDT
perl-Log-Dispatch-Config-1.04-9.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-09-21 12:42:16 EDT
perl-Log-Dispatch-Config-1.04-8.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.